ArduPlane issues with Pixhawk1 and ChibiOS

Hello all! I haven’t been able to build a working version of Plane for my Pixhawk1. Last time I compiled and uploaded to my board was around a year ago. Now if I build master (I’ve tried for a month), the board boots with no tones or COM heartbeat, but the pre-built binary still work just fine. What is the difference between a build from master and the pre-built? I have tried multiple computers, Win/Mac/Linux, different flight planners, and multiple times a week to see if whatever bug I have has been patched. I suspect chibios since I believe Plane was on nuttx last time I successfully built and uploaded.

My typical workflow is:
git clone
git submodule init
git submodule update --recursive
./waf distclean
./waf list_boards
./waf configure --board Pixhawk1
./waf plane

I usually upload the firmware with Mission Planner, but I’ve tried APMPlanner2 as well.

Another user seemed to have a similar issue here: Can't connect PX4Pilot after flashing Chibios
But none of the suggestions fixed it for me.
Any suggestions to try next?

Thank you!

I just did a MP update and re-cloned master today and… it worked! Whatever bug I had seems to be patched.