Can't connect LiDAR-lite V3 to Pixfalcon via I2C

I am trying to connect a LiDAR-lite V3 by Garmin to a Pixfalcon with copter 3.4.6 via I2C. I can’t enable the Sonar in the initial setup page the enable button is blacked out. After setup is complete sonarrange and sonarvoltage both show as zero, it looks like no input is coming from the LiDAR. I have wired it according to the wiring diagram on the wiki, and the LiDAR-lite V3 manual I have tried configuring some of the rangefinder parameters in config/tuning including RNGFND_ADDR, RNGFND_TYPE, and RNGFND_PIN it still didn’t work.

LidarLite v3 isn’t supported in Copter 3.4, only in 3.5 (still in beta).

Great thanks, it works now.

Hi, I had it working with Copter 3.5.0-rc2 beta, but today loaded 3.5.0-rc3 beta and the LiDAR Lite v3 stopped working. The enable button is blacked out again - any ideas? Thanks

I’m not sure what Mission Planner does on that screen. My only recommendation would be to look at the full parameter list and check you have RNGFND_TYPE set to 15.

Thanks, yes I did that already but did not solve problem. Will keep working on it.

Are you saying the LidarLite doesn’t work or the screen in MP is still blacked out? If it’s the latter then you need to open a topic in MP category.

I got it to work, had to reset the sonar setting to down - had changed it by mistake when upgraded to rc3.