Can't arm with RC controller but ok with Mission Planner

Hi guys,

so I am making my first homemade drone and went through all the making process.
Unfortunately I am having a problem at last step.

My problem is I can’t arm the drone using my RC controller. I tried throttle stick down and rudder right for 5 secs, throttle up and rudder right, throttle down and rudder left, etc. I think I tried every combination!
I am using Navio2 and RPi3B+.
When connecting to Mission Planner through UDP, I can successfully arm with the “Actions”->“Arm/Disarm” button.
When drone is powered on, Led is first solid green, then leds are flashing red and blue until motors are beeping three times, then led is flashing blue, then green, then fast green. Totally correct in my opinion. Then when trying to arm with RC, nothing happens, led keeps flashing green.
I went through all mandatory hardware steps on Mission Planner, everything went just fine. All-in-one ESC calibration went fine and motors could spin at the end of calibration when I pushed the stick up (when done manually, not with Mission Planner).

Just one small information : as I dit not succeed to plug the UART wire of telemetry in Navio board, I pushed harder as I found suggested on the internet… and broke the UART connector of the Navio board. Two or three metal pins were also broken, the remaining of the board is ok. This is why I am connecting Mission Planner through UDP, and will try connection with a USB/UART convertor when I will receive it…

Any help would be appreciated, thank you everyone!
Damien

Ok everyone…
It’s been a whole day I am trying to arm and just when I post this message I found the solution…
Unbelievable!
Actually, I was not pushing to the right the correct stick.
I thought it was left stick down and right stick right. I just realized it was only left stick, all the way down AND to the right.
I feel stupid :slight_smile: