Cannot up date to Copter 3.6.10 (SOLVED)

I’m moving a Black Cube from Plane to Copter and cannot get the update done. Mission Planner(1.3.68) connects fine to the flashed Plane version.

I check the “force bootloader” box, then after the “ignore the …” box, select the official Copter version. Then the new drop down pane appears and I select “Copter” and FMUV3.

MP downloads the file, scans the comports and that’s where it hangs, throwing the error message, no board found. MP appears to be trying on the same comport as Plane, in this case com7.

I’ve tried various sequences of rebooting the FC, then connecting, etc, but no combination helps.

@glacier051 Take a look at this post:



Great info. I’m just not doing this enough to stay on top of it.

I went to the site and found the “Black Cube” firmware directory. I then selected “Stable 3.6.10” | “CubeBlack” | “arducopter_with_bl.hex”.

At this point, it stumps me - cannot download that file.


Good day,
did you update your MP with the last release driver?

Nope. Will go do that now.



No joy.

I updated MP via the link on the Help menu button. Also had it check for “beta” updates, which it installed. I also note there’s another item called “Install Firmware Manifest” on the initital setup page now.

So, after connecting to the board on com7, I disconnect, start the firmware update using “Install Firmware Manifest”, select hexacopter official 3.6.10. The new drop down menu lists “CubeBlack”. Select it. Hit install.

The status bar shows MP downloading the file, reading the hex file and when it gets to "scanning comports, that’s where it stops.- error, no response from board.

My question is this what you refer to in your comment, update the driver? Or are you talking something different?


Well, it was a convoluted process involving an old APM…

By chance, a couple of days ago, I pulled out an old APM, after updating Mission Planner, to see if I could load 3.6.10. The strange thing was after plugging in the USB, the comport didn’t show up in the MP list. I checked Windows Device Manager and see another Com5 listed(in this case - the one in MP was for a bluetooth one and I was connecting via USB) but that port doesn’t show up in MP, so I set it all aside.

Fast forward to today. A friend is over and he suggests trying to load onto the APM(again). We see the comport problem and the friend suggests checking the comport settings. By absolute fluke, we decide to change the comport number to something else and that was the fix. We loaded 3.6.10 on the APM, then returned to the Cube. All went well after that.

So, if you’re having this problem - the update hangs on the no board found or searching comports

  • update Mission Planner to latest
  • plug in your USB
  • close MP if open
  • change the comport settings listed to another comport number in Device Manager, leaving everything else the same while the board is connected(so DM can see it in the system)
  • launch MP and you should see the new comport number
  • proceed with update