Cannot hovering, correct throttle setting method

I created a new multirotor drone this time.
Its pid or other flight was really good.
However, hovering is not possible.

The drone’s altitude increased rapidly even with a slight increase in throttle, and the aircraft’s altitude had been decrease dreadly with a small drop in throttle.

What is this problem?

There was no hunting phenomenon because of the pid tuning value for the z-axis.

The drone was not able to hover, flicking the ground like weightlessness, rising into the air again and again and again and again, and the drone was turned upside down at the end.
Here is my log.

I need your help. Thank you

You can see here that the motors diverge the higher you go with the FC even shutting down M3 at peak alt.
Your CW and CCW motors are imbalanced in thrust.
Check your motor order, motor levelling, prop installation, esc calibration.

You also have an increase in Z vibes with thrust so I would check loose or weak fixtures, rattling wiring and the like.

thank you for the reply.
I solved this problem very simply.
It was just a difference in sensitivity.
By reducing the p value for z a bit, I solved this problem.

However, I agree with the changes in the pwm level you mentioned.

Actually, I checked the output of the ccw motor gradually lowered when I removed the rotor and turned the motor.

Even this was a stab mode flight.
I had this problem without any gps intervention.

I now have to fix this.