Cannot connect telemetry radio to Mateksys H743-Wing V3

I’m having trouble connecting a Mateksys H743-Wing V3 to MissionPlanner via telemetry radio 915MHz.

I see alot of people had the same issue as me where after clicking connect, it will show “no heartbeat packets received” after timing out 30 seconds. But they were able to resolve the issue by switching rx and tx pins, or they had their radio plugged in incorrectly to their fc. I have tried switching rx and tx pins with no luck, and I’ve double checked my pins and they’re correct.

My baud rate is at 57600 and I’m using latest version of MissionPlanner.
I have uploaded plane V4 3.5 firmware onto the flight controller.

Here are some pictures of my fc and telemetry radios

Previously I had been running an older version of mission planner and the radios will link because both had solid green light although the fc still wasn’t able to connect.

Now I tried to use the newest version and the radios are only flashing green.

Not really sure what to do next. Any tips will be much appreciated. Thank you.

Why there is no led - blinking at leas in your radio ?
What is the pinout/port you using in the Matek to connect the radio ?

1 Like

Here are a few more pictures, sorry the first image doesn’t show the leds blinking.
Here they are actually blinking.

My pin configuration from radio → Matek is:
5V-yellow → 5V
Rx-gray → Rx7
Tx-blue → Tx7
CTS-purple → Cts7
RTS-green → Rts7
GND-orange → G

Your Telemetry radio’s should work as well with Cts and Rts not connected. Try that first?

1 Like

This is backwards. It should be:
Rx-gray → Tx7
Tx-blue → Rx7

1 Like

Cool it’s working.
So I did what HansHansHans suggested and removed the cables for CTS and RTS for now,
I also did what Yuri_Rage said to switch Rx and Tx.

Thank you guys for all your help!