Servers by jDrones

Cannot calibrate radio transmitter at10 RadioLink R10 receiver


(doug Wright) #1

I am very new to this and I have a remote mower I built 3 years ago & I want to build an Autopilot for it. I have the hardware setup and have been successful at everything so far… BUT I cant see the green bars on the Radio Calibration tab in Ardupilot Rover "MANDATORY HDWE "

I feel like the receiver /Transmitter are paired as they work fine for years without the Pixhawk from “radioLink"
I have double checked the wiring as " I UNDERSTAND IT” but I tried 4 different laptops and get the same result…
Does the USB cable have to be plugged in for this setup …or can it be done over 915 mhz telemetry radio?
thanks in n advance for any suggestions.


(Kenny Trussell) #2

Doug,
I am not familiar with that transmitter/receiver (I’m not much less new to this than you!). This is probably nothing new to you or any help, but what I use is a Radiolink T8FB transmitter with R8EH receiver (https://www.robotshop.com/en/radiolink-t8fb-24ghz-8ch-transmitter-r8eh-8ch-receiver.html). I have the S-BUS from the receiver connected to the RC terminals on the Pixhawk as described here: http://ardupilot.org/copter/docs/common-pixhawk-and-px4-compatible-rc-transmitter-and-receiver-systems.html#common-pixhawk-and-px4-compatible-rc-transmitter-and-receiver-systems. It just worked for me.
Kenny


(doug Wright) #3

Thanks Kenny , My receiver does not support S-Bus as far as I can tell. I ordered another one that does & works with AT10 TRx. So I will throw parts at it til it works…
As for the case of your using Linear Actuators for your steering being slow to respond. Have you seen the wiper motor servos made with a bell crank or a cam to activate the steering motors on a ZTR mower?
Doug


(Kenny Trussell) #4

Once I changed the configuration in the linear actuator control boards, I have had pretty good response. I still wonder about their longevity, though. It is a wait and see thing. But, I will look into the wiper motor servos idea for when I do replace them. Thanks.


(doug Wright) #5

I bought an S-Bus micro receiver and it seems to be working . I suppose the one I have with AT10 is not compatible with Pixhawk. There is a lot to learn on this. Thanks
Doug