Servers by jDrones

Canbus and Zubaxx


(Corrado Steri) #1

Hello, has any progress been made to support zubaxx gps/barometer canbus units?

I had zubaxx perfectly working on 3.4 than fron 3.5 and on the barometer stopped working, as i understand somebody is working on the canbus stuck, so i am wondering is i can expect it to work on the latest 3.6.x builds.

Corrado


(rmackay9) #2

I was not aware somehow that the Zubax baro stopped working on Copter-3.5. I would have thought it would work on Copter-3.6 but if it doesn’t we will try and get it working. Could you give it a try and report back?


(Corrado Steri) #3

Sure can, will test and report back.

Corrado


(Corrado Steri) #4

Just updated to 3.6 rc5 Chibios and selected uavcan GPS type but the option BRD_CAN_ENABLE is not there anymore. Maybe not supported yet on ChibiOS and i need to test it on Nuttx?

Corrado


(rmackay9) #5

Corrado,

I’ve never used the Zubax but I also don’t see the BRD_CAN_ENABLE on either the older NuttX nor ChibiOS builds.

@OXINARF tells me that the CAN related parameters now start with CAN_. So try setting CAN_P1_DRIVER to “1”.

Obviously we need to improve the documentation 'cuz I don’t see this anywhere on the wiki.


(Corrado Steri) #6

Thanks, will test and report back.

Corrado


(Corrado Steri) #7

Ok, just tested and looks like everything works, great!!

Just one thing, if i enable CAN_P1_DRIVER than i need to use can port 2 on the Pixhawk 2.1 and everything works. If i try to use can port 1 on Pixhawk 2.1 than it doesn’t work even if i enable CAN_P2_DRIVER.

So as long as P1_DRIVER is used together with CAN 2 PORT on Pixhawk 2.1 everything looks good, GPS is ok, magnetometer is ok and i DO NOT get anymore the “bad barometer” error message.

If some more testing is needed please let me know what combination you need to test and i’ll do it.

Thanks for your help.

Corrado

p.s. On this Zubaxx unit the node number was set by me with zubaxx comand line tool, so if any authomatic node assignation is implemented in these new drivers than it was not tested.


(Francisco Ferreira) #8

Hi,

For documentation on CAN, you can read http://ardupilot.org/copter/docs/common-canbus-setup-advanced.html

Regarding the Cube (Pixhawk 2.1), yes, the first port (P1) is wrongly labelled CAN 2 so setting P1 makes you have to use CAN 2 port.

Regarding the port 2 (CAN 1 in the Cube), are you saying that setting CAN_P1_DRIVER and CAN_P2_DRIVER to 1, rebooting and connecting to port 2 doesn’t work?


(Corrado Steri) #9

Ok, enabling both P1 AND P2 makes port CAN 1 on Pixhawk 2.1 work!!

In my previous tests i was disabling P1 when testing Port 1 on Pixhawk.

Corrado


(Francisco Ferreira) #10

We can probably make changes to make port 2 work without port 1 having any driver attached to it, but it’s not a great solution because port 1 will need to be hardware active, even if no driver is attached to it.


(Corrado Steri) #11

I think a bit of documentation and changing P1 to point to CAN 1 port on the board will be plenty enough. Thankk you for your help and work, it really work fine now.

Corrado


(Liang Tang) #12

https://discuss.ardupilot.org/t/gps-commpass-rgb-led-uavcan-module/30706?u=liang-tang


(Corrado Steri) #13

We are talking about a specific problem here on a specific hardware configuration. Please keep your commercial posts for yourself unless you can’t contribute to the specific argument.

Thanks