Can someone pleaseee help me find out what caused my quadcopter to crash by looking the logs?

I tried to take off in stabilize mode , as soon as it took off it started drifting left. I tried to give it a right roll command but it didn’t work and it crashed into some vegetation.

Quad , T motor p80, FLAME ESCs, 4 6S connected as 2s2P. weighting around 20 Kg

Things that I suspect might had an effect, ESCs might not be in sync. angular limits were set to 10 degrees. but input roll , pitch and yaw seem very noisy and strange.
Your help is greatly appreciated as I don’t know exactly what went wrong, and that was there just one thing wrong or more.

What size props do you have? Flying on default parameters with this craft is a really bad idea. Do you know about the Initial Tuning parameters? They can be accessed in Mission Planner from the Alt>A plug-in after connection.

And T-Motor Flames ESC settings:

30 inch Props
No I did not no about that Plugin!
For next test I will calibrate the ESCs again, set the parameters via the plugin.
But one thing I don’t understand is the values for Desired roll , desired pitch and desired yaw, It looks so noisy! I just increased throttle and after it started drifting to left rapidly I gave a right roll command. I didn’t gave pitch or yaw commands and still those noisy signals are there, can you give me your thoughts on that please?

Thank you! with these settings will I also need to trim the throttle PWM values on the controller?
Combination of those motors and 30 Inch props. can lift around 60 Kg at max throttle although drone weights around 20 Kg.

My thought are don’t worry about that until it’s basically flying. Also, increase the Angle_max paramter to something reasonable. You will need more authority than 10deg.

Alright! thanks, how is 30 degrees?

Sure, that’s fine. What kV are those motors and what prop pitch?

Kv120 , 10.9 inch pitch

OK, that propulsion/power system should be good for a 20kg craft.

1 Like

Hi Dave ,
I am trying to calibrate everything again and I have some questions that I couldn’t find any answers to them online, I appreciate it if you can help me. since this craft crashed twice I have to make sure that everything is working ok.
1- Should the calibration of ESCs come after the calibration of compass, accel. etc. ?
2- After the calibration of Escs I run the motors without the props, on a table, roll and pitch values are less than 0.1 deg. motors in idle mode rotate at the same speed. but when I increase the throttle their speed becomes different from each other gradually. is this normal?

  1. This doesn’t matter.
  2. Normal. Bench testing w/o props tells you almost nothing other than the motors turn and in which direction.
1 Like

Thanks for answering! I guess with new parameters and calibrations and no errors I got to go for the test.
one more question , my FC is really close to the PDB hence crazy amount of EM interference, I set the external compass as the priority (GPS compass) and this resolved issues with compass variance, my question is can this be problematic for the IMUs inside the FC?

No. But it’s typical that the internal compass(s) have to be disabled.

I am bench testing the motors. Motor 2 output always has a lower output than others.
@dkemxr what do you think?

Motor output while tied-down on the bench with no propellers is no indication of behavior when the propellers are mounted and the drone is flying.

Do not try to move the throttle stick to see if the motors operate well under those conditions.

Use the motor test feature to test the motor connection order. After that, go fly.

Got it. Thanks @amilcarlucas

@xfacta Hi again, I made a mistake , The ESCs are model ALPHA 80A.
and for MOT_THST_EXPO ardupilot tutorial suggests choosing the value according to prop. size , in that case 30 inch props. results in approximately 0.8. I appreciate it if you give me your feedback. Thanks

As I recall, the T-Motor Alpha ESCs linearize the PWM-thrust curve, so MOT_THST_EXPO tends to be around 0.2 for them.

1 Like

Could be. I asked them directly this question and they responded “none of our ESC’s have this function”. With the non-existent documentation from them I wouldn’t use their ESC’s.

1 Like