Can SBUS Out (SBUSo) and AUX pins be used simultaneously?

I want to control a Gremsy gimbal and a Seagull #REC together via a Cube . So far, I enabled SBUS out (BRD_SBUS = 1) and connected the gimbal using SBUS which works using Ch 8-11. I need 3 more channels to control the Seagull #REC and had hoped to use AUX Pins 4-6 but can’t get it to work.

Is it possible to use SBUS out as well as the AUX pins? I have tried setting the appropriate SERVOxx settings to RCINxx, RCPassThru, and disabled but no luck and run out of ideas!

Anyone out there able to help with this?

Further to my earlier post I am having trouble configuring the Pixhawk AUX Pins to output a RC signal.

The object is from a Taranis using 3 x 3 position switches and a X8R control a Seagull #REC via the Pixhawk AUX connectors. The X8R is connected by SBUS to the Pixhawk.

I have tried the followings without success.

BRD_PWM_COUNT = 6 so the AUX Pins are enabled.

As an example for Radio 12 or AUX 4.


Also tried


I have the Pixhawk ‘SBUS o’ connected to a Gremsy gimbal by enabling the BRD_SBUS_OUT

parameter but if the BRD_SBUS_OUT = 0 or disabled it doesn’t make any difference.

In Mission Planner the radio page shows the X8R PWM signals are correct but when a PWM meter is connected to the AUX pins the signals are not coming through.

If anyone can help with this it would be appreciated as I must have missed a setting somewhere!


I think it should work. It’s probably best if you can provide an onboard log (aka dataflash log) because the RCOU will show what’s apparently being sent out on servo output 12. It might be necessary to set LOG_DISARMED = 1 in order to produce a log without arming.

Ah, it may be necessary to arm the vehicle for the outputs to be sent or at least have the safety switch pushed or disabled (see BRD_SAFETYENABLE parameter).

Thanks for your support and I attach a log which tests the syststem.

I would like to use the Cube AUX channels 4, 5 and 6 to control a Seagul #REC using channels 12, 13, 14.

My configuration is as follows.
Taranis X9D and X8R RX which is connected by SBUS to a Black Cube. The cube has the SBUS out enabled and connected to a Gremsy Pixy U SBUS using channels 9, 10 11. The gimbal control works fine.

When the Seagull #REC is connected directly to the X8R using channels 12, 13, 14 it works fine.
The problem is that when I connect the Seagull #REC to the Cube AUX pins 4, 5 and 6 it doesn’t work.
To test it I have set the following. The Seagull #REC On/Off channels which uses channell 14 is connected directly to the X8R so I can turn the camera on/off. The other 2 Seagull #REC channels are connected to AUX pins 12 and 13 and have been set to RCPassThru and RCIN13 respectively.

SERVO12_FUNCTION = 1 (RCPassThru) Camera Record Still/Movie
SERVO13_FUNCTION = 63 (RCIN13) Camera Zoom
SERVO14_FUNCTION = 0 (Disabled) Camera On/Off

The log shows the RCOU giving the correct signals but when I attach a PWM tester to the AUX PINs they read 900 for all the switch positions.
I have either overlooked a MP parameter setting or there is a hard issue?
Any help would be appreciated!

Did you figure this out?

Yes, figured it out and the AUX problem was because the AUX rail wasn’t powered.

I did it this way

Cube AUX Pins to Seagull #REC Setup

AUX Pins

  • For the AUX pins to work the Servo Rail needs to be powered with 5volts. Use a BEC to do this.
  • Set BRD_PWM_COUNT = 6 so the AUX Pins are enabled.
  • For each AUX set of pins used set it to Passthrough
    E.g. AUX 4 or Channel 12 set SERVO12_FUNCTION = 1 (RCPassThru). This will allow the RC signal to pass straight to the appropriate AUX pins unaltered.
  • Then connect a cable from the appropriate AUX pins to the device i.e. Seagull #REC

SBUS Out to Pixy U

  • Connect a cable from the Cube ‘SBUSo’ pins to the Pixy U SBUS in pins
  • SBUS Out Center PWR cable is not needed.
  • Enable the SBUS Out pins by setting the parameter BRD_SBUS_OUT = 1.
  • Pixy U Channels example
    • Ch 8 – Mode
    • Ch 9 - Pitch
    • Ch 10 - Roll
    • Ch 11 – Yaw
  • For each channel used by the Pixy U set its SERVOxx_FUNCTION = 1 (RCPassThru)
  • The RTX radio will then directly control the gimbal
1 Like

You can contact me via i will help you to resolve this problem. I can attach the instruction files.

or check out in this link:

What is the purpose of the last two sets of pwm pins being set to be relay pins instead of normal pwm aux pins? I mean, why is BRD_PWM_COUNT = 6 not the default? Is there some good reason to have the last two as relays? What are relays for?

BRD_PWM_COUNT = 6 is just a copy of my setup where I have a Seagull #REC connected to AUX 4, 5, 6 so I needed all the AUX pins enabled.
So as I understand it set BRD_PWM_COUNT to equal how many AUX pins you need. I am no expert on this but it worked for me.

To control high loads with logic level signals. Easy enough to change the assignments.

Are you sure this step is required? It doesn’t seem right to me. In my understanding (correct me if I’m wrong) the SERVOx_FUNCTIONs are not directly related to a channel unless they are so set. For example, my Octocopter uses 8 servo outputs on the back of the Pixhawk, so I have SERVO5_FUNCTION, for example set to control motor 5. Then I am using Channel 5 for my flight controller… So not sure it makes sense that you would need to set the RCPassThru value for each sBus channel you plan to use.

If this is the case, then I am out of channels which match Pixhawk PWM outputs. My setup:

CH14 - Landing gear on servo14/AUX6
CH9-Gimbal RCPassThru servo9/AUX1
CH10-Gimbal RCPassThru servo10/AUX2
CH11-Gimbal RCPassThru servo11AUX3
CH12-Gimbal RCPassThru servo12AUX4

…So this would only leave me with 1 channel available for Seagull Rec.

I am hoping someone can comment and establish whether or not servo outputs on the Pixhawk can be used independently of channels. I am under the impression that creating the RCPassThru is a pass through to the PWM outputs, not the sBusout and that the sBusout is outputting all rc channels as soon as BRD_SBUS_ENABLE is set to “1.”

You could be correct and maybe the best way to find out is to try it and let us know? If you are only using Follow mode in the gimbal you don’t need roll and yaw control so use those channels for the Seagull #REC?

If I can get my board working again, I was planning to try it.

You are correct in that the input and output channels can be independently used. You can use the RC pass through to send those commands directly as mapped from the R/C input. However, there are also options for RCIN1-16 under each servo function. These allow you to use different R/C input and output combinations to create your own pass-through.

1 Like

Thanks. That clears up some confusion I’ve had about seemingly being able to pass through using two different methods and why.