Can only ARM when connected to USB

Maybe some kind of mixer is configured in this switch?

@setho I would recalibrate the RC and try to arm via throttle low + yaw right to understand better the problem.

B+ can apply 2S-8S voltage.
You can find it on the quotation page.
ArduCopter checks the FC voltage.
In the flight log, it is at 0V.

As it is for all of these board types. You will not get a Pre-arm error on these boards even if “Board Voltage” is enabled in the arming check bitmask.

@dkemxr @mura_mura what’s the name of the channel for plotting FC voltage? Does the cause here appear to be a lack of power to the FC?

FC voltage is not available in the log for that and many other Flight Controllers. This was the point I was making. If it is available (Pixhawk, Cubes, others) its PM>Vcc

1 Like

I’ve recalibrated RC and attempted to arm via throttle low + yaw right, but still no luck. I’ve attached the log files below. Really stumped and not sure to try at this point.

Nominal Arm with USB and Battery
1 12-31-1969 4-00-01 PM_arm_usbandbattery_throttle_stick.bin (813.6 KB)

Failure to Arm on Battery Alone
2 12-31-1969 4-00-01 PM_arm_batteryonly_throttle_stick.bin (103.7 KB)

This second log has like 7 seconds and no sticks movement, it is hard to evaluate what is going wrong… specialy because no Arm failed message is registered on the log file…

@dkemxr any thoughts about these logs?

Wierd that it’s not logging stick movement. Stick movement looks nominal in RC calibration

On vacation and cannot analyze logs,but sounds to me like rc rx is not being powered when on battery alone…check rc power when on batt

Thanks for taking a look. I’m getting 4.9V measured at the Rx with both configs (ubs+batt and batt alone), so looks to be getting enough power.

Nothing to see in the log. I think you need to try again. I would really be suspect of your power setup.

1 Like

Thanks for taking a look Andy. Do you have any recs on what else I should check on the power setup? So far I’ve measured the following:

  • voltage input to Rx - getting 4.9V
  • voltage input to GPS/Compass - getting 4.9V
  • Voltage at FC 5V output pad - getting 4.9V

I suspect this may be related to the addition of the BEC to power the servo. Let me know if you see any issues with the way I’ve wired it (see xfacta’s post)

What I would try and do is eliminate the power from the testing. If you disconnect the servo and it works then that is pretty conclusive

All the testing has been done with the servo disconnected (that was the first thing I tried). Can you clarify what you mean by ‘eliminating power from the testing’?

I essentially mean disconnect everything until you figure out what is causing the problem

The issue still persists after disconnecting the servo and BEC. Here’s what my power setup looks like with the servo and BEC disconnected.

Pretty standard for the most part, with the exception of how I’m grounding VTX and Rx. To reduce the number of wires routing to FC, I connected VTX ground to the Rx ground and Rx ground to FC ground Pad. I verified via continuity checks that all grounds on the FC are common, so seems like this shouldn’t be an issue.

Any thoughts on this setup would be much appreciated. I’m running out of things to check here…

Why have you connected the ground from RX to VTX? Why not plug straight into the connector.

I can’t believe this is the problem, but worth trying.

Please can you also post a disarmed log as well. What error do you get when you try and arm? If the RX is CRSF or ELRS then you can use yaapu to see the error.

Main reason is to minimize the number of wires routing to FC for packaging reasons. VTX is mounted right next to Rx, so location-wise it also makes sense to just add a jumper connecting the grounds together.

I’m getting the ‘Err: Compass-0’ error when trying to arm. See this log: 2 12-31-1969 4-00-01 PM.bin - Google Drive
I tried recalibrating the compass, but the issue still persisted.

Per discussion with CRSF, the LED I’m seeing on the Rx is indicative of a power supply issue to Rx.

Looking at the power at Rx with my scope, I’m seeing a voltage trace that drops suddenly and recovers when trying to arm with the batt only config (see photo below). With the batt + usb config, voltage remains steady throughout the arming sequence.

One note on the physical wiring: The Rx wires are ziptied together with the VTX wires, the collective bundle is routed to the FC for packaging reasons. (don’t think this should be an issue, but just fyi) The wires are also quite long at 180mm.

A few other things I tried

  • splitting the VTX and RX grounds, still no luck
  • swapping out for another Rx, still no luck

It looks like the compass error is only when you switch it on - I’m not convinced that’s the problem. There are no other errors in the log - I don’t even see an attempt to arm. If you are worried about the RX that would certainly prevent it arming if the RX drops at the moment you arm - I have seen that on CRSF receivers before and is usually down to being connected to a UART that does not have DMA. The drop in voltage you see is concerning and its certainly true that being connected via USB will change the power chracteristics

1 Like

I isolated the problem to the FC. Swapped out the FC and the problem went away. Looks like a defect with the power system of the board itself

1 Like