Can only ARM when connected to USB

I’m able to arm my quad when connected to Mission Planner via USB and battery, but can’t arm when connected to battery power alone. The blue LED on the flight controller continuously flashes.

I suspect it’s related to my hardware config rather than a failsafe given that I’ve disabled GPS failsafe for troubleshooting.

Hardware config (see below for wiring)

  • Kakute H7 V2 flight controller
  • Servo gimbal connected to M5 motor signal port and GND and B+.
  • ESC 2 port powered by 5 volt BEC (regulated down from 24V battery)

Attempted Troubleshooting

  • Took multimeter measurements between the 5V and GND pin for ‘USB + battery’ and ‘battery only’ configs. Got 5.26V for both configs, so it looks like the board is getting power.
  • Disconnecting the servo (but leaving the BEC connected) did not help. This means that the issue likely isn’t due to excessive servo power consumption reducing the power to the FC.

Kakute Flight Controller Pinout
24V to 5V BEC

Any help here would be much appreciated.

What does Mission Planner present as the error?

I don’t have a telemetry radio so I can’t see when connected to battery alone. No data logs are saved either since the vehicle is unable to be armed. There are no errors while connected to USB and arming.

You should have a cable from the ESC to the flight controller for M1 → M4 and power(B+), ground, ESC telemtry.
And disconnect the Servo 5v BEC to the FC 5v supply.

1 Like

Thanks for the feedback. I tried that but still no luck arming on battery power alone (servo works as expected).

Set LOG_DISARMED = 1 and try again, then grab the .bin log and upload it somewhere. Share the link to it.
The change back LOG_DISARMED = 0

1 Like

I’m getting COMPASS-0 error, so looks like I may need to do a better calibration. Weird that It allows you to still arm when connected to USB but not battery alone.

Here is the log file: 3 12-31-1969 4-00-01 PM_arm4.bin - Google Drive

There’s no 5vdc VCC recorded, I’m not sure if those flight controller do measure that or not…
You only have PWM selected for the motor outputs and I think you could use DSHOT, even bi-directional DSHOT.

Yeah, I don’t think this one measures the 5vdc input to FC…

Copy on DSHOT, but this would be unrelated to the arming issue, is that right? Underlining issues seems to be poor compass cal

There are MAG0 reading so it’s connected OK.
Go outside, get a good GPS 3D fix and then do the compass cal.

1 Like

Went outside, got a good GPS 3D fix and redid the compass cal. Still no luck with arming on battery power alone.

Here’s the log for the latest arm attempt post compass cal: 2 12-31-1969 4-00-01 PM.bin - Google Drive

This log do not show any arming attempt.How are you trying to arm it? Via RC? Your sticks do not move in this log.

You have RC_OPTIONS set to check for neutral throttle when arming.
It looks like the throttle channel is within the deadzone around MIN, but maybe not low enough?

1 Like

I’m arming via an arm switch I’ve configured. I verified that the switch works by successfully arming when the quad is connected to MP via USB and battery. But I am unable to arm when connected to the battery alone. I’ve also tried arming with the throttle stick, but no luck there either.

1 Like

Hey Mark, I’ve verified that the throttle stick is physically at it’s lowest position (per RC calibration) during the arming attempts

1 Like

I’m baffled. Seems like you should get some response to the arming switch, but I don’t see anything in the log. Do you hear the “arming failed” buzzer notification?

1 Like

Super weird. No buzzer notification, but am seeing a flashing blue LED on FC. I’ve attached a log below for arming while connected to mission planner via usb and battery. Log shows arm and disarm as expected followed by physical arming/disarming of the vehicle.

@BrunoBagarini See below

I’ve successfully flown another quad on this exact same FC where everything worked fine. The only changes for this vehicle were the addition of a gimbal servo (wiring shown above), different compass/gps and esc mounting location relative to FC, and different length/routing path of wires. So there could be more magnetic interference, but still doesn’t explain why it arms ok when connected to usb.

1 Like

The quad is arming with RC7, but also disarming with RC7. Is that on a momentary switch?

1 Like

Negative, it’s on a 3-way switch

The arming status is following RC7, so the trick will be to figure out what RC7 is going low.