Servers by jDrones

Can not hover and always rotate to its side

hi
I have APM hardware and qual+ frame with firmware 3.2.1
I did calibrate compass & accelerators couple of times but my drone has not hover and always rotate to its side , according to following screen shot, data log az always very negative high and I don’t know whether its natural or not , also I did log the rcout for 4 motors as per image and it seems after arming rc outputs have significant differential value whereas APM board is totally level
any hint is really appreciated

You need to post a flight log from the APM for anyone to even guess what is happening.

Check you APM direction.
Motor directions?
Props?
Motors level?
Bench test with props OFF, arm and tilt.
Do the low motors speed up and high motors slow down?
Same when you use the Tx?

thanks @mboland , I ran couple of calibrations & test procedure check such as sensors , props & leveling but it seems roll/pitch has bias constantly thus the each motors axis rcout(rcout1 vs rcout2 & rcout3 vs rcout4 ) has constantly different output around 30%
I don’t know where to start to compensate this bias
I’ve tried change AHRS Trim Roll/Pitch but nothings very significant happened

attached is the tLog file2018-06-16 20-25-12.tlog (598.5 KB)

Getting the flight log from the APM is described here

Your transmitter should have NO trims set on your sticks.

I have had the odd flight controller have this bias that always turned out to be a bad FW upload.
Simply loading plane or rover then reinstalling copter a doing a new setup fixed the problem.

thanks @mboland, I have no trims and following is flight data

 Log File C:\Users\Private\AppData\Local\Temp\tmpD532.tmp.log
Size (kb) 211.8642578125
No of lines 3465
Duration 0:00:00
Vehicletype ArduCopter
Firmware Version V3.2.1
Firmware Hash 
Hardware Type 
Free Mem 0
Skipped Lines 0
Test: Autotune = UNKNOWN - No ATUN log data
Test: Brownout = GOOD - 
Test: Compass = GOOD - mag_field interference within limits (4.23%)

Test: Dupe Log Data = GOOD - 
Test: Empty = GOOD - 
Test: Event/Failsafe = GOOD - 
Test: GPS = FAIL - Min satellites: 3, Max HDop: 99.99
Test: IMU Mismatch = NA - 
Test: Motor Balance = FAIL - Motor channel averages = [1662, 1585, 1510, 1597]
Average motor output = 1588
Difference between min and max motor averages = 152
Test: NaNs = GOOD - 
Test: OpticalFlow = FAIL - 'FLOW_FXSCALER' not found
Test: Parameters = GOOD - 
Test: PM = FAIL - 4 slow loop lines found, max 23.88% on line 2947
Test: Pitch/Roll = GOOD - 
Test: Thrust = FAIL - Avg climb rate -3.69 cm/s for throttle avg 983
Test: VCC = GOOD - 

1 1-1-1970 3-30-00 AM.bin.log (211.9 KB)

really appreciated for your hint

Your not making it easy.
The .log file has not RCout data.
Can you turn on more comprehensive logging, try another test and post that log file?
Just from the .tlog you have some major issue with your motor setup.
Either the frame setup is wrong (x or +), motor direction is wrong, props are wrong (have you got the CCW and CW on the right motors) or the direction of the APM.


Check your basic hardware setup.

thanks @mboland for your concern , but I did double check procedures and motor test and it seems for roll this bias is lesser than the previous effort , however I’m supersized for lack of RCout as you said, because I already see it in log file as per following image , but I’ve tried to upload new log file

RC out for pith control (motor 3 & 4 in quad + configuration )

RC out for roll control (motor 1 & 1 in quad + configuration )

Hi Mike, what is the log visualisation tool you used for analysis above? Is it for Windows or Linux? Lokks very nice. Much better than standard Mission Planner log tool.
Cheers,
Tomasz

It for Macintosh, APM Planner.

Mike, thanks for prompt answer. Have a good day.
Tomasz

Servers by jDrones