Can not connect to Pixhawk via usb after formatting sd card, no visible COM port

Hi Everybody,

im aksing your help because i really dont know what to do, i tried everything i could find on the forum or anywhere else on the internet.
My problem is that one of our agricultural spraying drone was acting weird when i tried to download the log files via usb cable. We use the Pixhawk Cube with 3.6.12. When i selected the log files i wanted to download, it started allright, but the green line did not strated to move, and also after a few seconds it beeped, and than i get a message that the download is finished. But unfortunatelly the log file was very small and none of the analyzer programs were able to read them.
Than i formatted the Micro sd card, as i read everywhere, but after that, i can not connect to the Pixhawk anymore. When i try, i get a Windows message, that there is something wrong with the device, and the windows can not recognize it. Also i can not find any COM ports in the MIssion PLanner and also none in windows device manager. I think it has something to do with the driver. I already tried the driver package that first deletes the old drivers and than installs the new ones by Michael Oborne, i reinstalled the mission planner, but the same happens every time a connect the cable.
And also it was working fine before the format of the micro sd card.

It would be a huge help if somebody could tell me what is wrong, and how to fix it.


Hi, Not sure about a solution but
SD card should be formatted with FAT32 so check it, or your sd card is simply bad?

Thanks, i used FAT32 to format, and i dont think the sd card is the problem, everything was working fine before the format.