Servers by jDrones

Camera gimbal control not functioning


(Phil Romford) #1

After updating to FW 3.5.2 I no longer have gimbal control from my Tx. The image below shows my settings in Mission Planner:-

My Tx channels are 6 for tilt and 10 for roll. When I found it was not working I set up servos 11 & 12 for tilt and roll, however this doesn’t work. I don’t remember now what the servo settings were when all was working. I searched the parameters for other params that may help, but to no avail.
Can someone please help with this.
Thanks in advance.


(Phil Romford) #2

I forgot to add some details:-

Pixhawk PX4. The gimbal tilt is on RC11, roll on RC14. I’ve noticed that with the latest firmware 3.52 that in the full parameters list there is no longer a parameter for RC_FUNCTION, so how is now possible to set the correct function.
I know that the gimbal operates correctly, having checked it directly from an Rx.
The camera trigger function still works correctly.


(mike kelly) #3

The parameters have changed. The new parameters are CHx_OPT and SERVOx_.
https://www.rcgroups.com/forums/showthread.php?2852885-Controlling-external-devices-like-Gimbals-and-Lights-with-a-Pixhawk


(Phil Romford) #4

Thank you Mike! I’ll take a look.


(mike kelly) #5

Are you actually using an Alexmos board via a serial connection? IF not that is your problem. Set it to servo.


(Phil Romford) #6

It is an Alexmos board, which I had already set to servo.


(mike kelly) #7

Your screen shot shows it set to “Alexmos serial” that is why I commented. If you have the gimbal setup for servo connections you need to have that parameter also set to “servo” also.

Cheers


(Phil Romford) #8

Thanks Mike I hadn’t realised that. It works now.


(mike kelly) #9

Good deal! Glad to hear it.


(Jonathan Rhodes) #10

Dear Mike
I have been having much the same problem with a Tarot t4 3d gimbal. In Copter 3.4 only tilt would work. I have a Taranis x9d plus transmitter and 8XR receiver. I set the Type to servo. I would put the tilt on RC9 (AUX1) and configure through mission planer. The radio channel was set to 8 (Ch8). I tried to add pan on RC10 (AUX2) with CH9 controlling, configured through mission planner but this would not work.

I then used the SBUS. I could use the SBUS out on the Pixhawk to control the Tarot gimbal. I had to configure the radio channels in the Tarot configuration software and enable the BRW_SBUS_OUT to 1 and set the RCx_FUNCTIONS to 1 to enable pass through. Mission planner gimbal settings were removed.
This would allow pan and tilt.

Since upgrading to 3.5 its all gone wrong!
As the parameters have changed I am not sure if the SBUS option will work.

I have gone back to putting tilt on AUX1 and configuring mission planner camera gimbal, Sero9 for tilt and Input Channel set to 8. Nothing happens.

I have since read your link and used the Full parameter list, removing the settings in mission planner camera gimbal. I left Ch8_OPT at 0 and set SERVO9_FUNCTION to 58, to pass through CH8 from my radio to AUX1 on the Pixhawk. Once booted up, radio on, gimbal power on, non GPS lock flight mode selected and the safety switch on, nothing happens. The gimbal levels itself and responds to the airframe moving, but there is no manual tilt possible from the radio. I have not bothered with the pan function yet.

What am I missing? Is Ch8_OPT = 0 correct? What is the point in the camera gimbal page of mission planner?

Any help would be appreciated. I know everyone’s set up is different but this is getting beyond me.


(mike kelly) #11

First the Camera Gimbal page in mission planner is just a helpful GUI to set the parameters. It does the same thing for you that setting the paramters manually does.

I can’t comment about s.bus out because I have never used it but what you are doing looks right.

CH8_OPT=0 and SERVO_FUNCTION=58 would be correct for what you want to do.

If you upgraded from 3.4 to 3.5 without erasing the parameter memory it might have corrupted entries. When I get things that should work but act weird instead I clean house, so to speak. In the advanced parameters page reset parameters to default and go to the trouble of redoing all your cals and settings.

I have not played with my gimbals since 3.5 so I can’t say if something was broken during the upgrade which occasionally happens.

Try other combinations. Ch10 in to Aux 1 out. Just to see if there is something wrong specific to a particular channel use.

Make sure the gimbal works directly off the X8R just to confirm there is not a problem with the gimbal.

So there a few ideas for troubleshooting, good luck!


(Jonathan Rhodes) #12

Thanks Mike

I will have a go at these. There has to be something, probably a small thing, that I am overlooking.


(Erik Groeneveld) #13

Don’t forget MNT_TYPE : see different options to control the type of the gimbal…


(mike kelly) #14

He is doing a passthrough so the mount type should not matter.


(Erik Groeneveld) #15

Mike you are correct, but in the past I have seen that this parameter had quite some influence in the correct handling of these channels…

I am using serial out to control a storm32 gimbal, and in that case it’s a must to specify the correct Gimbal type.


(mike kelly) #16

Absolutely true, but in this case using parameter value 58, passthrough is telling Arducopter not to interfere. Just pass along the pwm values from the selected input channel to the selected output channel.


(Jonathan Rhodes) #17

Hi again Mike. I am pleased to report that I have made some progress since yesterday. Before trying a full rest and starting over I decided to give the SBUS option another go.

My 8XR receiver is connected to the Pixhawk via SBUS.

I have tilt set to control from radio channel 8 (dial) and pan set to radio channel 9 (dial). I have also set channel 12 to a two way switch so I will be able to set the Tarot gimbal mode. Once the channels are assigned on the radio the functions are set in the Tarot ZYX configuration program, with a USB connection to flash the Gimbal controller on set up. I have left the Gimbal mode control set to “unmapping” in this configuration program, for now. The receiver type is set to SBUS and the default mode is Pan Follow.

In Mission planner I have to do the following in the full parameter tree.
Set BRW_SBUS_OUT From 0 to 1.
Set SERVO8_FUNCTION from 0 to 1, enables pass through.
Set SERVO9_FUNCTION from 0 to 1, enables pass through.
Set SERVO12_FUNCTION from 0 to 1, enables pass through.

No settings are made in the mission planner camera gimbal page - Mission planner doesn’t know the gimbal exists.

I can now power up the Pixhawk, power up the gimbal, depress the safety switch and the gimbal stabilises as the airframe moves with tilt and pan functioning perfectly via the radio.

I should be pleased at that. However I now have a new question.

From the excellent description of the use of CHx_OPT and SERVOx_FUNCTION for Copter 3.5 is see a contradiction implied by my setup which has me confused about exactly what the SERVOx_Function is referring to.

What I took from your description was that my Servo settings would be controlling Servo output 8, Servo output 9 (AUX1) and Servo output 12 (AUX4). These are all outputs from the Pixhawk.

However, on my copter nothing is connected to these outputs on the Pixhawk. Instead in my case the SERVOx_FUNTION numbers seem to refer to the inputs from the radio channels I set for tilt (8) and pan (9) [12 is not set to do anything yet]. These radio channels now pass through the PIXHAWK, thereby directly controlling the Gimbal.

I must be missing something obvious.


(mike kelly) #18

That is the way it is supposed to work. Since you are using S.BUS out. Those parameters tell the Pixhawk to take the ch8,9,12 and route them to the s.bus out as a passthrough. I need to add that to my article.

I need to test but I assume that in your example ch9, 10, 11 could/would be directed to the normal outputs while the ch8,9,12 are sent to the s.bus output stream. If you have a servo laying around try controlling it from Ch10 rcin and SERVO10_function=60 and connect it to AUX2 and see if it works.

Glad things are working.


(Jonathan Rhodes) #19

Hi Mike

The Servo idea was a good one.

I had CH14 spare on my radio. I checked that CH14 on the radio worked in Mission planner first and checked the servo worked with a tester before starting.

I then set SERV10_FUNCTION=64 to get ch14 to AUX2.

Once powered on the safety switch was then armed.

With power from the USB this doesn’t work.

When power from the battery it does.

I will now try the Gimbal again, just in case I did not power the Pixhawk from the battery last time.


(mike kelly) #20

Remember the output bus on the Pixhawk is not powered. So it makes sense if the external power you use to power the gimbal or servo is not turned on then the USB can’t/won’t power anything connected to the output bus.