Calibrating Skyviper V2450


My skyviper V2450 stop arming and power the motors so after reading it seems presumed that it was that sensors lost calibration, the quad is got latest firmware , i did re update all firmware in case, also did the default factory reset.

the problem is that i can only calibrate the accelerometer the magnetometer calibration does not react or shows the progress bar as stated when rotating the quad. neither the other calibration of barometer.

any ideas why this could happen and how to solve it ?

is there any custom firmware with deafult calibrations values i could load so to have a point to start from that so to recalibrate. just an idea so to test something else.

thank you in adavance.

I’m assuming you have tried powering on both your drone and controller while they are sitting right next to each other. (Less then 1 meter) I was watching a video where it said that that they have to be super close when initially pairing them at the factory.

Also if you talking about the Rotating Magnetometer calibration not promting you, it doesn’t. I also was waiting for a prompt but I just had to start moving the 2450 on all axis to move the progress bar.

Hi, thanks for reply.

Yes they are close and pairing properly.

I think there is some other problem, i have rotated in all axis for quite a while.

After accelerometer calibrated confirmation, i still dont get the real time lines visualitation from the sensors.

I have also downdrage the firmware to try but no luck either, same result.

Not sure what else to try.


Hi ,i found something interesting in the flight parameters most of them have disappear , there use to be a huge list in here , and now only those.

Hi I have also tried export the params from new skyviper gps unit via MissionPlanner then load in non working one, accelerometer seem to work and respond correct in MP window but says bad logging and prearm login failed. in the skyviper web config its the same as before no data in the sensor debug windows .

suddenly today i cold do factory reset and calibrate so woking again but really no idea what happened and how to fix if it happens again , quite strange. anyway i think all good for now. cheers ;D

hi , problem persist, after new power reboot same problem again, bad loggin . i tried with and without sd card

so there is something wrong somewhere.

it looks like the internal memory either is got wrong values or that it did not save the values in it .

so there is something wrong somewhere.

Please navigate to the log storage directory and take a screenshot.

Hi peterbarker, in skyviper the paramter list in flight paramter tab doe snot show the list of paramters properly is like empty .

in MP , paramerters are there with wrong values ten i add the parameters original that i saved from a working one and shows changes , after that if i go again to the flight parameters in skyvier then jus tthen shows the paramters and i canstart calibration, but i did steps before i could fix it for one go after doing all calibration and all became the same and stop working.

Hi , i tried the following workaround and turn on off a few times and seem to keep working for now.

re-updated all firmwares.
load and write pre-saved parameter from a working skyviper in MissionPlanner in the config full paramter list.
and just in case i did skyviper web config flight paramters all restrore defaults.

still i get the bad logging messages though but i can arm and calibrate now.

still i get the bad logging messages though but i can arm and calibrate

OK, that’s good.

Do you have an SD card inserted?

Hi , by the time i tested i was not sure if there was sd or not. i tested now again and it seems only when no sd card inserted.

Hi , by the time i tested i was not sure if there was sd or not. i tested
now again and it seems only when no sd card inserted.

Since logging is done to the SD card, I think it’s entirely reasonable
that logging be unhealthy if you don’t have an SD card in :slight_smile:

Hi Guys, how are you doing ¡¡

I,m still getting this bad behaviour of loosing whole parameters even if not changing anything in parameters or software.

it seems like internal memory or where the parameters are saved is lost or removed in some cases situations ?

symtopms, you power the drone, no arming wihtout prompt , then you conect to the web config to see what happens ,and see that many parameters are lost without reason.

only way to recover the drone after this. it is to use mission planner and load a original parameters file , if you are lucky to have one if you saved prior that then recalibrate all again.

btw i get bad logging even with sd card in. even one that was working before in the same drone without changes so it seems it looses it or get corrupted after the paramters too.

btw , is any skyviper firmware updates coming soon ?


That’s probably a parameter issue; check that your LOG_BACKEND_TYPE is 2

Hi peterbarker, thank you for hint.

That parameter seem to be right , this is for the logging part right ?

any idea about the lost of parameters and calibration configuration and how to fix ?



Additional to the previos messages,i found something curious.

some of the times when no arming i check if parameters are there and all procedure explained before.

but this one is new parameters seem to be fine, then i do a motor calibration and after i can arm without rebooting. then if i reboot i get to the same situation i can not arm if i dont do the motor calibration, strange, anyone experience that ?

but somehow seem to be related to magno

anything else i could try update test to fix or find the reason of all those problems ?


I’ve been watching this a while…but i’m going to go out on a limb here.

I’ve noticed that sometimes, if you connect to APWeb too early right after a reboot, that when you go to flight parameters page, onyl a few parameters will be shown. Only after the FC has been booted for a few minutes will all the paramaters show on that page. There is a chance that is what you are seeing. I know the suggestion sounds trivial, but try refreshing the Parameters page after you have been connected for about a minute.

Hi lordneeko, thank you for your reply.

I tried your suggestion and i,ll take it into account for future too, although that was not my case now.

what is really strange is this thing about after calibrating the motors i can arm after it right away without no reboot and fly it normally.

then i reboot and i can not arm again.

i have do a fresh firmware update of all components then a full calibration. but this persist . usually either it says bad logging or mag failed.

now i power on the skyviper no arming i do the motor calibration then i can arm again , very strange. reboot and same …

why could it be that behaviour cause from ?

Well observed. What you’re seeing is the external GCS interrupting the
parameter flow to APWeb. Eventually APWeb will time-out its failed
streaming parameter fetch and try again.

ArduPilot only supports streaming out parameters to a single target
mavlink ID at a time, so the problem’s not trivial to resolve. Best we’ve
got so far is to proxy the parameter requests on the Sonix board.