Servers by jDrones

Building RealFlight8 Models


(tridge) #1

This is a discussion for people building models for aircraft in RealFlight8 for ArduPilot.
See this documentation for general information on using RealFlight with ArduPilot:
http://ardupilot.org/dev/docs/sitl-with-realflight.html
Building a model involves two main things:

  • building a physics model with the RF8 physics editor to match the target vehicle
  • building a 3D graphics model so that the vehicle looks correct (and control surfaces move correctly etc)
    I am hoping we will build up a set of nice models for ArduPilot that can be used by users for testing, and by developers for adding new features to ArduPilot
    I have created a git repository to hold the models here:
    https://github.com/ArduPilot/SITL_Models

Vtol delivery wing
Dual-motor tailsitters
Dual-motor tailsitters
(tridge) #2

@lorbass and I (well, mostly lorbass!) have been working on a model of a vectored tailsitter based on a Caipirinha. Here is a video of the latest attempt to import the model into RF8


(lorbass) #3

Step back.
After eliminating the Texture errors, other errors occured which explain the error message in RF8 at the beginning of the vid.
The FBX Export Plug In with 3DSmax has a lot of restrictions and is really poor.
Especially it accepts only orthogonal or perpendicular axis.
This makes moving the elevons correct impossible.

Therefore I try to install the exporter PlugIn from Knifedge to export KEX Files directly.

About RF8. Can you see any model with moving Parts non orthogonal ? (Rudder, Elevon…)
Regards, Otto


(tridge) #4

yes, there are V-Tail aircraft, and the control surfaces do move correctly.
I can do a video of one if that helps


(lorbass) #5

Thanks, would be strange if Not.
The PlugIn of KniveEdge for DS3max 2012 does not work on DS3max 2015.

But will have to look later about axes.
In the meantime worked on other issues, like Textures.
Strange FBX Exporter in 3DSmax, exports Materials (and their not available textures) which are not used in the scene.
May be, because of used in an earlier job.

Here Test 3 with overworked Materials.
https://drive.google.com/open?id=1vckgmtD1O34-WC0i6NpW0-UlZ2V71VPa

In case of no importer issues, please check if you can move the elevons (~CS_LMA, ~CS_RMA) with the axes angle,
and Motor Tilts (~CS_TILT1, ~CS_TILT2), names according to the conventions of RF8, recpectively KnifeEdge.
Regards, Otto


(lorbass) #6

Got RF8.
Import without errors.
Starting model produce message: Unknown error. When pressing OK, RF8 crahes too.

I wrote to KnifeEdge Support to get an explication about this issue.
Don’t waste your time if not clear before.
Regards, Otto


(lorbass) #7

Short approach.

Found the reason for the issues.
The FBX exporter does not support complex objects in 3DSmax in this case the motor carrier.
Here the Wing without this objects.
https://drive.google.com/open?id=1OxncZjFL8AEC9lVBb4JXEC5F0A8qXe8u

Tested in RF8 with the data of the Standard Plane/Wing "Slinger"
Not much succes in bringing back to earth without Flight Controller…e.g. MissionPlanner.:slightly_frowning_face:
The elevons moves correct, I think despite error message while exporting.

How about with your TBVS Tridge?

Will redesign motor carriers with low complexity parts to complete the Caipirinha.
Regards, Otto


(tridge) #8

Thanks Otto!
I’ve imported this into gihub as a RFX file:


I’ve done a rough physics model for it. I used 8x4.5 props, 1800kV motors, 2200mAh battery
It is underpowered in hover for some reason, needing full throttle to climb.
In forward flight its horrible - the CoG is probably way off.
@kd0aij is going to have a look at it. He got his Stryker to match the real aircraft quite nicely.
Cheers, Tridge


(tridge) #9

Hi Otto,
It turns out the CoG problem was because I had the wrong airfoil, I was using a ClarkY. I’ve now switched to a NACA 014 and its much better. I also switched to 4S battery to give more power. I don’t know why 3S isn’t enough given your real model is 3S.
I’ve done a video of your model flying in RF8:


I set it up with the parameters from a recent flight on your real model. The tuning isn’t quite right, but its not too bad.
Thanks so much for your work on this!
The model and parameters are here:

Cheers, Tridge


(tridge) #10

can you tell me your prop diameter and pitch, and what motors and battery you are using? I’ve just put in guesses for now.


(lorbass) #11

Hi Tridge,
Great, I’m happy that the procedure works.
I’m surprised, how close to real flight it behaves.
Thanks also for your motivation for this “job”, makes fun.
The model is not finished yet, thought as test only.
I will continue with the motors and motor mounts which can tilt.

The scale is not correct yet, because measures in RF8 in inches, an 3DSmax set in mm.
I scaled it down by 20. The real wing span is 870 mm.
May be, a reason for the underpower.

I use:
Motors 2212, 1000 kv
Props 10x5.5"
Weight 900 gr.
Battery 3S, 3000mAh
CG 150 mm from Front, actually.
Due to the pitch up of the Tilt and Elevons in FBWA, I think it should be more backwards.
Regards, Otto


(tridge) #12

yes, it worked quite well!

RealFlight can use mm or inches - its in the settings menu. I have it set to mm for editing the physics model.

thanks!
I’ve also found I can edit the model you’ve produced in blender. I’d like to eventually learn to produce the whole model in blender. That will give anyone in the community the ability to create a model without having to buy 3DSmax.
Cheers, Tridge


(lorbass) #13

Was then the model not very to small?

Should I use mm in the future?

I tested Blender yesterday, but for me every thing different and “hard” to learn.
But you are right, 3DS is expensive and has to much functions which can’t be converted to FBX.
And so, I have to test each object if it can be exported according to the building procedures used.
For this use, it’s a little bit an overkill. But used for 20 years, I stay with it.
But as recommendation for others I finde it’s good to check if Blender works too.
Regards, Otto


(lorbass) #14

Added the motors and motor mounts.
The Tilt Units are named ~CS_TILT1 and ~CS_TILT2
Here: https://drive.google.com/open?id=1GAfz8VKN1yQ6FRyusXfSZw5zpr2dyzfn

Can’t find out in the RF8 Editor how to assign Servo3 and 4 to the Tilts.
Tried to import the caipirinha2_EA.RFX downloaded from Github.
After selecting it is to see, but after OK RF8 crashes with error message: Unknown issue.
Threrefore I can not learn from your work.
Regards, Otto


(tridge) #15

I suspect the problem with loading the model is that component names are the same as existing names. I just tried to load your model and it crashed for me. I then binary edited the fbx file and changed “2.tga” to “5.tga” then renamed the two files to match, and it loaded fine.
It may also work to delete the old version of the model before trying to import it again.


(tridge) #16

is that the weight with the battery?


(tridge) #17

~CS_TILT1 does appear in the model, but ~CS_TILT2 doesn’t. Looking at the binary, I see a typo where it shows up as ~CS_TILT2 (ie. an extra binary character after the ~CS)


(tridge) #18

video of the latest build, with the typo in ~CS_TILT2 fixed


(tridge) #19

I’ve found why the tuning was off - I needed to set the prop wash factor on the motors to 50%. It now flies very well with the parameters from Otto’s flights.
I’ve uploaded a new version of the RFX file to github


(tridge) #20

knifeedge has created a discussion topic for the LINK system we use for RF8 with ArduPilot here:
https://www.knifeedge.com/forums/forumdisplay.php?f=116