Build Error following Wiki

Hi,

I am following the development directions posted here https://ardupilot.org/dev/docs/building-setup-linux.html and then the build directions here https://github.com/ArduPilot/ardupilot/blob/master/BUILD.md.

I have tried configuring different boards, created new ardupilot local directories from git with no luck. All I have run is the board configure for my pixhawk 4 and then ./waf copter.

This my error, any help is appreciated

as: unrecognized option ‘–64’

Waf: Leaving directory `/home/mitch/autopilot/ardupilot/build/Pixhawk4’
Build failed
-> task in ‘/home/mitch/autopilot/ardupilot/build/Pixhawk4/gen-bindings’ failed (exit status 1):
{task 140045786813264: /home/mitch/autopilot/ardupilot/build/Pixhawk4/gen-bindings main.c -> gen-bindings}
:
{task 140045786813264: /home/mitch/autopilot/ardupilot/build/Pixhawk4/gen-bindings main.c -> gen-bindings}
’ gcc -std=c99 -Wno-error=missing-field-initializers -Wall -Werror -Wextra -o gen-bindings …/…/libraries/AP_Scripting/generator/src/main.c ’

Good day, which version of Ubuntu are you using?

Hi Dave,

It is a fresh install of 20.04.01 LTS, this was my next fault finding move.

Mitch

I have a new fresh install of 20.04.01 and have run the installation process again. My new error is

ccache: error: Could not find compiler “arm-none-eabi-g++” in PATH

my current $PATH is

/usr/lib/ccache:/home/mitch/ardupilot/Tools/autotest:/opt/gcc-arm-none-eabi-6-2017-q2-update/bin:/home/mitch/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin

Any different thoughts on where I am going wrong?

Just try re install the gcc arm or you can use the previous Ubuntu 18.04.