Bug Neo pixel and buzzer not working on 4.3.3 build arducopter

I m using speedy bees f405v3 with esc stack combo i was building a drone with this but couldn’t figure out the Neo pixel led with active buzzer did not work at all tried everything I can but seems to be bug? I tried this exact led in my other quad with Omnibus f4pro V2 and it works just fine I don’t know the issue I did wired led to a separate output group to not have any conflict as ardupilot wiki says for that board can anyone help me on this link for the led is down

The flight controller i m using

post your parameters and an indication of how you are wiring this

1 Like

This is how i m wiring according to the diagram

Neo pixel on s9 pad and the buzzer i m using is active one so using b- for buzz signal

Ground and 5v on respective pins tried different ground and 5v pads but it won’t work

Please post your parameters as well. The buzzer is only a beeper so you wont get many noises

1 Like

I will upload param files tomorrow as I will go to the office

speedybeef405 parms.param (18.4 KB)

Just tested mine and neopixel worked fine - try setting servo9 function to 120 rather than 122

It was already on 120 as default so I changed it to 121 and then 122 but didn’t work and also where to put buzzer signal wire on the board is it on b- or b+ ? And the wiring inm doing with ground and 5 volts is that ok too?

You need to have a battery connected - 5v rail won’t be powered otherwise

No but the receiver hae power even with the usb only connected to pc the receiver i m powering with 4v5

if this helps I’m facing the same situation with a pixhawk 1 with 2mb flash and using aux pin 5 or 6 for the neopixel. FMUv3 bootloader

The LED sometimes turn on but not flashing (disarm) one led is yellow, another one green or off. LED is powered by 5v BEC on the servo rail.
Same LED work perfectly with same settings on cube orange.

This is on arduplane but should make much difference

Show me your params fie

It looks to me that that LED/Buzzer module is not compatible with the flight controller. You might need a dedicated buzzer connected to BZ+ and BZ-. Where did you connect BZ+ of the flight controller to the buzzer module? I’m guessing you did not connect it.

Using a voltmeter and measure the voltage between BZ+ and GND. If you get 5V, then the LED/Buzzer is compatible with the FC. Otherwise buy a dedicated buzzer.

On the buzzer led module there is not buzz minus or plus it just have buzz signal wire i think it’s a active buzzer it doesn’t need buzz - + the module has 4 wire ground 5 volts led and buzzer that’s it I even tried different led to this boards but that work either I tried this exact buzz and led combo on my other fc Omnibusf4 pro and it worked fine there I don’t know what’s the case with this buzzeand led combo or the board it sef

There is a BZ-. Did you try shorting this BZ- line to GND? Did the buzzer beep? Did you measure the voltage at BZ+ on the FC? You might want to also measure the voltage on the +5V line. Let us know the results.

What we are trying to establish here is which line is the flight controller sending a signal when it wants to sound the buzzer? Is it BZ+ or BZ-?


Yes I connected buzz minus to buzz minus on the board didn’t work at all

I didn’t short any pins to ground cause I was afraid that i might burn something on the board

In short, that LED/Buzzer module is not compatible with your FC. Buy an active buzzer and follow the recommended wiring connection.