Servers by jDrones

Boat zig zagging when in Auto

Hello,

I have been trying to get my arduboat to go in a straight line for the last few days.

I have 3d printed a larger rudder to see if this was the issue. No change still the same zig zag.

I have tried changing NAVL1_PERIOD up to 20 and down to 2 with little difference.

I’ve change TURN_radius to 2m, no change.

Not really sure what else to do? Any help would be really appreciated.

Thank you.

Post a picture of the boat along with your parameter list and a log of an auto run.

Most likely bad STER pid tuning. As David said, an auto run will help us figure out what is wrong, and a few manual turns at cruise speed would also help.

1 Like

Also follow this string of information; you’re not the first to have a wobbly path boat. John Easton's battle with 'Wobbly Path' - [NOT SOLVED]

1 Like

John was, is, using vectored steering. This is a bit of a problem

Well, yes to a point. I’m guessing that the STER parameters are not adjusted correctly and that thread will shed some light on to the analysis of how we try to get them correct.

Boat Settings.param (13.3 KB)

This looks like a vectored steering type of boat. send the parameters.

It’s not. It is prop and steering.

I also reduced the motor size reduced so max speed about 2m/s. No sure if that could be effecting it?

Your ATC_STR_RAT parameters are not tuned at all.

Sorry David, I’m not sure what these are? Will look them up now. Thank you for the help.

Hi, i had a same problem with my boat, in auto mode, she swam in zigzags.
Spent quite a lot of time to adjust the parameters (about 10 hours). Not I’d say that with all were worked out, but boat now swims adequately (https://youtu.be/1IywUuRiJfs). Full list parameter’ll attach!
Accurately remember, that first got hooked for parameter STEER2SRV_IMAX, under his increase controller is beginning to more aggressively steer and try to keep course, in further reduced significance this of the parameter, that would governance was more smooth.
The next parameter NAVL1_PERIOD, a low value leads to a low level of response to a control error, a large value causes the course to return aggressively, i stopped at the value of 25 seconds.
And third this PID’s, STEER2SRV_D as me it looked not gives nor what good, only makes the boat more nervous in managing. So I set 0.
STEER2SRV_P large values lead to overshoot, small to understeer, just need to pick up. I was approached 0.4.
And the last output parameter STEER2SRV_I, it greatly affects the zigzags, I set to 0 and then gradually added. While the value is too small the boat can not keep the course as soon as it starts to stay the course, add a little more. Larger values immediately lead to overshot and zigzags.
I use APM 2.6 with firmware rover 3.4.2
PIDs
boat.param (4.6 KB)

A couple of things. STEER2SRV_FF is 0. That’s no good. Also cruise throttle is more than throttle max. I did not think 3.4.2 was good for an APM 2.6

Small values of STEER2SRV_FF (<1) did not give any result, large values led to zigzags.

“Also cruise throttle is more than throttle max” - agree, on fact he swims with throttle max.

“I did not think 3.4.2 was good for an APM 2.6.” - what’s good? As I understand it further APM support is discontinued and this is the last available version?

2.5.1 is the last for APM 2.6. STEER2SRV_FF will most likely be >1. Then the NAVL1 is turned up to mellow out the zig zag after the STEER2SRV P,I, and FF are set reasonably well.

Thanks, I will try to continue to configure!
3.4.2 seems to be working!

I plan to upgrade to omnibus f4, to use the latest rover firmware.
Omnibus would work well with the latest versions of the firmware?

Servers by jDrones