BLHeli32 Dhot300-1200 Arducopter3.6.7- sometimes some engine does not start

Hi all, I have a problem with shot and blheli32

ESC: Xrotor 40A blheli32 dshot1200
FC: Pixhawk “1”
Motors: Tmotor 4006

It flies perfectly, in fact I have to say than it works really really well with default tuning, tmotor4006 and 15" props

but some times some motor do not spin when i arm. it usually works and flies perfectly, eventually all motors fail, and some times only one motor fail and the other 3 motors works.

I have some screenshots of blheli configurator (pixhawk pass through). the motor than do not work seems to have “Input Frames Bad”

Also tested dshot300, no calibration and same problem.


I think that’s just too fast for ardupilot… I get a few bad frames even at 600. 300 seems to work fine.
The loop rate in arducopter is just 400hz, so it’s not updating the ESC’s nearly that fast.

Also, I have issues when I select auto timing… Motors might not spin up until I give them some throttle. So if you changed your timing, check that too.

-Edit - I just noticed your last line that 300 does it too.
Then I’m not sure.

Hi wicked1,
I confirm i am using dshot300 in this two screenshots.

It seems an initialization problem of ESC blheli32. We did a flight with dshot1200, when all motors start then you can fly normally.

but with dshot1200 seems to fail many times

In dshot300 or dshot150, It usually works (all engines start), once in 10, one of the motors fails.

In both cases, if I connect the pixhawk to a USB and then i remove and reconnect the battery (something like do a reset the ESCs) then always work

So i understand than ESC don´t need any initialization, also the pixhawk is sending a correct signal in both dshot150 and dshot1200

why some engines do not start?

I have the same “problem” with Hobbywing xrotor 40A (no blheli firm , just the factory one)

When I arm and give throttle some time the front right doesn’t start and sometimes the front left, but when the throttle reach around the 45% the motor that didn’t start from beginning with the others ,starts and the copter fly great.
This happens on altitude hold , postal hold , loiter, but on stabilize all motors start from beginning

I don’t know why but it doesn’t bother me

Thats weird!, do not exactly the same problem.
I am testing in Stabilize and my motors do not start even move the throttle to the maximum.

Make again ESC calibration

I am trying to do throttle calibration, I have tested all possible but it seems ESC do not enter in throttle calibration when signal is Dshot.

I have found this:

“-PPM_Min and PPM_Max are now disabled for DShot, as the end-points are fixed, and ESC calibration isn’t needed anymore
-In Betaflight, min_command and max_throttle are ignored with D-Shot
digital_idle_percent replaces min_throttle
-unsynced_motor_output is removed for DShot as it’s no longer needed”

Could it be detecting the wrong protocol?

Check on values the min max pwm for ch3

PWM values of throttle channel coming from the radio is very very near from 1000uS to 2000uS

I repeat than multicopter works perfectly, i am flying with oneshot125, and i can fly with dshot300, dshot300 works almost always. it flies also en dshot1200. I have to re-start several times until all motors spin but then it works perfectly.

In any case I’d like to use dshot1200 because it is digital and it seems to fly ultra-stable. I usually think that these things are hardly noticeable, but in this case I think that it improves a lot.

Are there someone using dshot with no problems?

Yes… 4 arducopters all on dshot300-600. I fly daily. I did have some problems w/ motor starting, but in one case it was a bad esc, and in another it was the blheli-32 settings.
I think in general, my blheli_s esc’s have less issues than the blheli_32 ones… Not sure why.

Sure, I have more than 30 mini quadcopters and they are all blheli 32 dshot600

With Arducopter? Last firmware? Can you say me ESC brand/model?

I’m using a couple different Speedix ESC’s, and aikon ak32, and Airbot Ori32.
But like I said before, they’re all 300-600… I haven’t tried 1200. (Not even sure if these ESC’s support that speed).

ok, i will test a new quad with another ESC model and another pixhawk

One of my speedix esc’s was bad and had the same sort of motor starting issue. But it was always the same output… Front right, in my case… I returned it, and the next one worked fine.

Changing the timing to Auto, and… update rate or something (sorry I dont remember the exact parameter name) in the blheli config also caused motor starting issues for me.

Hi all, I am a new user and I have the same problem. When I connect the battery and I arm the copter then one or even two motors do not spin and I am running dshot150. It worked perfectly without problems for 2 weeks and then it started to do display the incorrect behavior. I have bad frames on one esc as soon as I connect the pixahwk to blheli suite. As soon as I disconnect it then all motors work fine. I changed from auto timing to 16 degrees and I got the seme issue. I heard that 23 degrees is recommended so I will try this last set up maybe changing also pwm frequency from 48 to 24 khz but I am running out of ideas here. I was wondering if any of you figured out what the problem is. Thank you!

try removing the SD card

Than you for your reply Peter. I tried to erase the EEPROM and reinstall the firmware but nothing. You think the SD card has too many logs? I have 169 logs and some of them are 50 MB… could be that the I just reached a point where the SD card is starting to be too full for the AC3.6.8?

Edit: I just checked and I have a total of 1.8 GB of log files in my SD card, is this too much ?

I had this the other week on my octo, I put it down to me messing about in the firmware, I found as the SD card got more logs on it motors were less likely to start. If I removed the SD card they all start every time. Possibly it is a proper bug, as I say try without the SD card, if that fixes we can try and find the bug.

Hi Peter, this is actually very interesting since it might explain why it worked well for two weeks and then suddenly started to have problem. In the last few weeks I did many long flights and I filled the sd card a lot. I will try to remove the sd and see if the problem persists. If not I guess I should empty my sd card right?
Thank you!

Edit: one thing I forgot to mention is that when I connect my pixhawk 1 to blheli suite via passthrough and I press “read settings”, I am getting many bad mavlink messages such as bad gps, bad gyros, compass variance,… Probably some incompatibility between AC 3.6.8 and blheli32 firmware? However the messages disappear after 5 min or so, they do not seem to be a big issue but anyway I think this might create some troubles during power on ?