BLHeli problems

Afternoon all.
Running into a bit of a problem with BLheli on a Pxracer Pro. Just upgraded to the pro and notice a couple things.
First when I power up the drone one ESC beeps later then the rest. Not sure this is a concern but calling it out.
Second when I try to read the config for the esc’s I only get 1 that’s ESC 1. I don’t’ get the rest.
I did when it was the old pixracer R14…but not now.

Any thoughts would be appreciated.


This is par for the course with BLHeli I am afraid - there are some very board/MCU/ESC dependent issues which I have struggled to resolve fully. 4.1 is different and I would at least expect passthrough to work, but the arming issue may or may not be better or worse.

Hey Andy
So your saying what that the passthru or the single esc being late is a problem your aware of and is proving to be hard to nail down. If so I get that big time. IT guy here.

It just surprised me since the R14 worked fine.

So is arming an issue…I have not armed it as yet. Just getting it ready to test arm when I noticed I couldn’t get into the ESC and got that late beep.

Yeah we get that too. It seems to depend on the ESC itself AND the flight controller in various combinations.
An old Pixhawk 1M almost always works from config, even if our newer FC’s dont.
We’ve got Holybro 4in1 45A ESCs that never give any of these issues, and Holybro 4in1 65A ESCs that are “particular” about doing the config and BLHELI motor tests. Startup is as you say, one ESC almost always beeps after the rest.
But so far they’ve never given any issue in flight and have worked perfectly.