BLHeli Pass through on 4.0

I’m having issues getting BLHeli passthru to work on Copter 4.0
I’m using a Kakute F7 mini with a Tekko32 mini 4-in-1 Esc
I’ve set SERVO_BLH_AUTO = 1
When I try and connect BLHeli32 following the instructions in the log it connects ok but thinks the motors are running:

any idea what I am doing wrong? Also note it says I am using ArduPilot 3.3 which seems a bit weird

Ok solved my own question. You really do need to enable DShot for this to work. I enabled DShot, “Calibrated” the ESCs, rebooted and then everything worked like a charm

Yes I used dshot 150. It’s possible that the calibration step was what was required as this was the first time I had powered these ESC’s so a lot of things not configured.