Servers by jDrones

BLHeli_32 telemetry only with auto telemetry on

Hello!

I am with the telemetry configuration of my new ESC Tekko 32 65A metal 4 in 1, all the motors work ok with Dshot150 but the only way that the ESC sends telemetry to the Pixhawk The Cube Black is when I activate the “Auto telemetry ON” in BLHeliSuite, if not, there is no data. Here is my configuration:

And the telemetry port configurated is the Serial4

There is something that I am doing wrong, but I don’t know it.

Thanks!!

Try settig the debug parameter and see what output you get

Hi @andyp1per

I have set that parameter and SERVO_BLH_TEST to 1 to test first motor, and this is the output:

imagen

How are you telling whether you have telemetry or not? Its only supported on mavlink2 so you need to make sure your GCS setup supports that

Because in the “status” tab in the latest Beta of Mission Planner I can see the temp and voltage of the ESCs if I activate the option “Auto telemetry on” in BLHeliSuite. But if that option is disabled, all that information is 0.

So make sure that SERIAL0_PROTOCOL is set to 2

Yes, that is correct, serial0_protocol is set to 2

RCOut is PWM1-12.
I thought DSHOT is needed for BLHeli telemetry,
Try to set SERVO_BLH_MASK

Yes indeed, or set MOT_PWM_TYPE to 4-7

That solved the problem, now MP shows RCOut: PWM:1-8 DS300:9-12 and when I push the safety switch, the telemetry appears.

So thank you very much @RainFly and @andyp1per for your help.

And I didn’t see that parameter in the wiki (https://ardupilot.org/copter/docs/common-dshot-blheli32-telemetry.html#connecting-your-escs-for-use-with-dshot-protocol-and-blheli-32-features) so I think that it would be a good idea to make a mention of that.

Servers by jDrones