BlHeli_32 missing parameter - SERVO_BLH_BDMASK

Greetings. I’m trying to set up telemetry for BLHeli_32. And I do not find the parameter SERVO_BLH_BDMASK, it is not in the list at all.

What are the solutions to the problem?

My setup
BLHeli_32 DYS Aria 35A
Pixhawk 2.4.8
Rover 4.1.3

1 Like

What do you have MOT_PWM_TYPE set to?

What version BLHeli_32 is flashed to the ESCs?

Are you running a bidirectional DShot capable Ardu firmware? (usually ends with -bdshot, or noted in the readme).

There isn’t one for that Flight Controller.

Another Flight Controller that does have a BDshot target…

you dont need to use that parameter for regular blheli telemetry thats only for the bidirectional Dshot telemetry that uses the same wire as Dshot. your using BLheli telemetry via a separate serial port.

I can’t get any telemetry from BLHeli at all.

send a log so i can see all the parameters

2022-01-25 23-36-16.tlog (293.9 KB)
I still don’t know how to make sure that ESC works with Pixhawk in DShot mode, not PWM.

enable SERVO_BLH_DEBUG to get more information in the messages screen

it should say when starting up, 8 pwm, 4 gpio 2 dshot. or something similar.

I mean a bin from the pixhawk. your tlog is just showing 12pwm no shot.

do you have the escs connected to the AUX ports, the regular motor outputs are not dshot compatible on pixhawk 1.

connect your ecs to AUX 5 and AUX6 and set your left and right motors to SERVO13 and SERVO14.

With such settings , my motors are not controlled )
2022-01-26 00-07-02.tlog (402.1 KB)

That’s another tlog. The .bin log file is on the flight controller.!AvxBxpvRfGIgkIINqK8CgrBRkmrWAw?e=G0swHR
Bin file

change SERVO_BLH_PORT to 0, thats for the port your configuring from not the port esc telemetry is connected to.

SERVO_BLH_OTYPE to 4 for DSHOT150 to simplify things, the faster speed doesnt help rovers.

change SERVO_BLH_MASK to 12288 for channels 13 and 14

change SERVO_BLH_3DMASK to the same.

You won’t get Dshot out of Aux 5&6 (chan 13&14) with BRD_PWM_COUNT set to 4.

thats right you cant do that on 4.1, he would have to use 9 and 10.

Or set BRD_PWM_COUNT to 6.

I think all you need is the above and
MOT_PWM_TYPE to a Dshot protocol

Then the banner message should be PWM 1-8, Dshot 9-14

1 Like

Dshot reverse is broken in 4.2 currently, so you get telemetry or reverse but not both.

Ha, there is that :grinning:

Hooray, it’s working! Thank you so much @dkemxr and @geofrancis ! !

A new question, there were errors, but the motors are working and there is telemetry.

Error :ESC: Bad CRC on 1
ESC: Bad CRC on 2

P.S. It’s a bad idea for me to use one Pixhawk for several models, and different firmware versions… :crazy_face: :crazy_face:

1 Like

Disable this and it will magically go away:

The odd bit of bad data will be present, not a big deal I don’t think. You could see if you have the latest firmware for the ESC’s.