Servers by jDrones

Binding to Other Transmitters

I have been in contact with Matt from SkyRocket about this and he said at one point, Tridge or others were able to bind the SV to an Orange DSM module. I have tried binding to a variety of Spektrum transmitters (DXe, DX7 v2, LP5DSM) and my DSMX hack module in my Taranis and none of them are able to bind to the vehicle. I have also messed with the protocol in the parameters on Mission Planner and have gone back and forth between DSM2 and DSMX and have not been successful.
Is anyone else able to bind with something other than the stock transmitter? I can easily program my Taranis to get the PWM values I need to mimic all the functions on the stock radio but I just don’t want to be out in the cold should the stock one quit working one of these days.

This parameter?
BRD_RADIO_PROT=1 # for DSM2 compatible transmitters
BRD_RADIO_PROT=2 # for DSMX compatible transmitters

Yes, that’s the one I modified and couldn’t get it to work with any of the radios.

I have an Orange DSM2/DSMX module coming for the same purpose, I’ll be interested to see the replies.

Is everyone else also not able to bind with any other transmitter? Would really be interested to connect somehow.

hi everyone,
Binding to other transmitters can work. I originally developed support for the radio in the SkyViper using my taranis with an OrangeRX DSM2/DSMX JR module. I also tested it the other way, using a skyviper TX with a spektrum RX.
Here are some tips that may help you get it working:

  • setup your TX to send just 7 channels
  • setup your module to use DSM2 if you can. I have had it working with DSMX, but it is less tested
  • on my orangerx module, I use the “single flash” mode for testing. That module actually supports 4 different protocols (no flash, single flash, 2 flash and 3 flash on LED). The single flash mode is one of the two DSM2 modes
  • set BRD_RADIO_PROT to 1 for DSM2 protocol
  • set BRD_RADIO_TELEM to 0 to disable the skyviper telemetry. The telemetry protocol is a custom one that is not understood by any other TX (source is available if you are curious how it works)
  • when you start the bind in the web interface you will get an error if you are connected using another MAVLink TX. That error comes from it trying to also start bind on a serial connected radio (which you probably don’t have). Ignore the error.
  • you may have to try to find several times, depending on your module. The orangerx only sends bind packets for a very short period of time, and the channel scanning for bind in the skyviper can miss them. Try multiple times.
  • have a GCS like MissionPlanner or MAVProxy connected when you bind, watching the RC_CHANNELS MAVLink message, so you can see activity when you bind
  • if you’re using a switch based TX (eg. taranis) then don’t try to get all the action buttons setup, instead set all of the TMODE_* actions and modes to disabled, and set FLTMODE_CH to your preferred flightmode channel then setup normal ArduPilot FLTMODE values as usual. Trying to emulate all the switches will just cause you to go crazy, as the UI is oriented towards pushbuttons, not switches.
    I’ve only tested this with two DSM2-compatible transmitters (the orangerx module and another low cost DSM2 compatible radio). It is likely that it won’t work wtih them all. The DSM2/DSMX protocol varies a lot between implementations.
    Basically this is not a real DSM2 implementation, I tried to make it DSM2 compatible as best I could, but no guarantees.
    Cheers, Tridge
1 Like

Has anyone been able to do this?
I am using a 4in1 with no success.

well, I have, but I assume you mean anyone except me :slight_smile:

Lol, I have found this Line “set BRD_RADIO_PROT to 1 “ already set when I connected to MissionPlanner. It flies fine with the stock controls, I just wanted to try the taranis. I followed your instructions from above, I cannot get it to work, maybe I need to update my 4 in 1 ?

I don’t have a 4-in-1 so I can’t try it, I only tried it on my orangerx JR module. I don’t even know if it works on all of the orangerx modules, as mine is quite old. Sorry I can’t be more helpful!

Oh no worries , I like to tinker.
Thank you for your willingness to help.
Is it possible to put in another exit?

another exit? I’m not sure what you mean

Rx, LoL. Auto correct striked again

So, as a follow up, I was finally about to get this to work on my SV. To be clear, I am running a module that I stole from something like a DX5e or something like that back in the day that would allow me to run DSM2 and DSMX and then put the transmitter module in one of the hack kits. It has worked very well for a lot of things so far and I like the fact that it has model match and such, although it’s only up to 20 models.
Anyway, to get this to work, I had to go through Tridge’s instructions. My module only puts out 6 channels to be aware of that if you’re using a hack kit. You’ll only get 7 or 8 if you use one from a DX7/8 or if you get the OrangeRx module from HK.
I set my Taranis to run in DSM2 mode. Haven’t tried DSMX but you might see why.
Set BRD_RADIO_PROT to 1 as indicated
Set BRD_RADIO_TELEM to 0

Use the web interface and hit bind and right after, put the transmitter in bind mode. Repeat as many times as necessary until the green LEDs quit blinking on the SV. After you do it each time, give it 5-10 seconds to see if it bound. I found I tried too often and didn’t get it enough time. Be aware that I had to do it nearly 10 times to get it to stick. You may need to hit bind on the Taranis right after you click it in the web interface. Try some varied combinations but it will work.

Once you do that, then do the rest of the stuff that’s in there. For a little clarification, I just changed TMODE_ENABLE, or whatever it’s called, to DISABLE (I think it’s 1?) and wrote to it. No need to blow out all the other TMODE_* parameters as once you disable it, the rest won’t show up in Mission Planner.

As Tridge stated, make sure FLTMODE_CH is correct and then set all your flight modes like you usually would. I also turned off geofencing but might turn it back on again later.

Be sure to run a transmitter calibration. Be sure to hold the bird down because I got the channels wrong somehow and also had everything backwards too at first but the rest is your typical setup and it should work just fine.

I also got this to work following Tridge’s instructions, both with a Taranis and an old Turnigy 9XR, with a stock OrangeRX module.

No problem binding, but I had to reconfigure some channels (compared to a typical ardupilot setup) on radio. Throttle and Elevator were swapped in my case.

Some additional info, if this may help others. For stock Orange RX transmitter, check manual, setting it to DSM2, 2048/11ms (single flash) is pretty straightforward: Hit bind button 3 times quickly. It then cycles through 0,1,2 or three flashes. Keep doing it until you get one flash.

Also remember that with a Taranis, you need to change model settings to enable external RF (disable internal RF), and set PPM, also channel 1-7.

As said above, using Mission Planner calibration page helps to see what’s going on, especially what each channels do.

Thanks guys! It works! I was not using the “ bind button “ on the viper web interface.

Just FYI , I’m using the banggood 4 in 1 module with 1.6 .

1 Like

Thanks to all for the guide. I successfully got my SV flying with the Taranis and an OrangeRx module. As was noted it took several tries to Bind and the channel order needed changing but fairly straight forward.

1 Like

I have a Spektrum DSM2 module in my Taranis. Any chance of this binding to a SkyViper or do I need to get an Orange module? I tried the tips in this thread without any luck.

This is a very fun product - thanks to all who made it happen.

What module do you have? I use a 4 in 1.

One of these in a Taranis X9D+.

Servers by jDrones