Big 30Kg turbine heli tuning AC4.1.1


I follow heli tuning guide, and tuning ff and yaw is perfect.

Also I activated the HNOTCH to 17Hz (1000Rpm rotor governor) with 1st, 2nd and 4th harmonic.

Vibe is ok.

When I pass to roll pitch pid tuning, I can’t grow the D term above 0,001…
I see directly vibrations appearing.
and I always have 1°AMPLITUDE oscillations on roll / pitch.

So, to be able to put up D term, do I need to down standard 4,5 ANG PIT/RLL P ?

there is another solutions?

Also due to kerosene movement, and with ILMI R/P to zero, machine cannot stay perfectly level in stabilise.

but in the logs I can see I term on PIDR and PIDP … Why? it should be to 0 level du to ilmi 0 in hover flight no ?

I think to put ilmi to 0,1 to get this issue off.


Please excuse me for addressing you so impersonally, but I don’t know your name yet.

I was also amazed at the small D and P values. Even with small values ​​I had oscillations. Bill @bnsgeyer calmed me down, see my thread here

As I have already written to Orson,

I have done very well by using the parameter defaults that Bill gives for his Autotune2.

In his instruction PDF on page 4, Bill lists all the defaults for the autotune. With these defaults you can start the manual tuning also excellent. I have made good experiences with it.



Does your heli want to tip more and more to one side or does it slowly drift away to one side.
Would it roll over without countersteering or does it stay aligned but not on the spot?



@kuspower unfortunately you will not be able to raise the D gain any more than that. You are exciting an instability in the rotor system. It is common with all heli’s when tuning the Rate P and Rate D gains. It is best to tune the Rate P and Rate D for the pitch and roll axes separately. Each axis will have a different Rate P and Rate D gain. After the they are tuned then increase the angle P in each axis to improve how well the actual attitudes match the desired attitudes. I wouldn’t go much above 8 for the angle P gains. If you start seeing oscillations while raising the angle P gains then back off until they go away.

Heli’s with single main rotor and tail rotor will not remain level in hover. They can’t. They have to lean to the right (rotor spins clockwise when viewed from above). This will keep the the heli from drifting. The ILMI gives the integrator enough authority to hold the desired attitude in a hover. So you really want to set this to 0.08 and allow the heli to lean in a hover.

@bnsgeyer Hello Bill,

I always continue to learn from your comments, thank you!



1 Like

Hello, so its normal to have little p and d gain on this heli.
I also understand than pit and rll controllers must be tuned separetly.
Copter stay around 2deg around center ilmi zero on hover
Also atc_hovr_rll is tuned to -285 centidegrees to conter the tail rotor trust (main rotor ccw)

Question is regarding roll:
Ang rll p to 4.5
Rat rll p to 0,01
Rat rll d to 0,001
Accel rll max to 32000
Rat rll vff to 0,15 (tuned to approach rat rll)

I have little oscillation on rll
Mooving up rat rll d to 0.0011 oscillation goes up.
Reducing ang rll p to 4.1 heli is very slugish impossible to maintain attitude to hold position in alt hold so using tune feature i’m not able to let this value to land so i reput it to 4.5 before.

So to get off this rll oscillations I have 2 options in my opinion:
Reduce ang rll p and tune rat roll d?
Reduce acc rll max and retune vff and retune rat rll d ?

Im thinking that maybe 32000 acc rll max is to much for this heli and vff is tuned to high?

You can check log where i tune the rll vff here: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

Hello Henri, it stay aligned on the spot but with ±2deg error. wich is quite dificult to control in stabilise mode!

1 Like

Thank you bill for your reply.

about ilmi, where to check effect on the dataflask logs?

with ILMI set to zero, I have I term on the logs PIDR???


in my opinion, you are tuning too much parameters at one time.

I would start again with the parameters from the list form Bills autotune2-pdf.

Then follow the instructions from the Tuning Wiki.

I would keep the increments of the P and D values very small. Halve the values from which you get oscillations.

In my last tunings, I always took the default values from Bill for the I-values and left them as they were.

I fly scale helicopters of the 700 and 800 size with 6 to 9 kg.



Where can you read the 2 degree error? Or is that just an estimate by you.

From your answer I still can’t see clearly if the heli tilts in one direction or if the heli drifts in one direction.

What would the heli do if you would not de-steer in Stabi mode?

In my opinion, This is the reason it feels slow to respond. This value is too low for this heli. You can use 50000 and that should be good for that size. Leave angle P value at 4.5.

All heli’s have very low values of rate P and rate D.

Don’t have much time today to write but just wanted to pass that along.

Sorry I was thinking of another user when I first responded. That’s why I modified the post. 50000 should be good for your size heli

With Roll params as follow:
Ang rll p to 4.5
Rat rll p to 0,024
Rat rll d to 0,001
Accel rll max to 32000
Rat rll vff to 0,15 (tuned to approach rat rll)

you can see that we very badly follow des roll… (in blue you see my roll inputs…
you can see the oscillations I talk in the little sawtooth you can observe in actual roll…

Ok I will test to put 50000 acc rll max for check.

I suppose that I must to retune rll vff?

Also I remain 4.5 on ang rll p.

About ILMI, there is a way to check its action on the dataflash logs?

Yes. Probably and you should be looking at rates instead of attitudes for judging VFF.

Hopefully you are using larger values of ATC_INPUT_TC. you’ll want to use values closer to 0.2.

Look at the integrator PIDR.I. You will have to enable PID “logging.

in the log you can see PIDR I thats non zero…

while I’m flying hovr zero speed…
and H_Option set to 1 (leaky I)

Thank you so much for your help Bill :wink:

Atc input tc is set to 0,15s, is too low?, you want I set it to 0,2?

ang lim tc is set to 1…

Yes. That is what you want. The integrator is doing its job.

Correct. 0.15 is too low. You can try 0.2 at first and see what you think. It will take a little longer for the aircraft to reach steady-state attitude but that will be more in line with what the aircraft is capable of.

From what I know about the code we do not use this parameter

Thank you bill, I put ATC INPUT TC to 0,2.

I have questions about Yaw :
At what value I must set servo 4 trim? I set to pwm value hover in flight? its ok or not?
as it’s turbine, it take 30sec to reach 1000rpm from idle.
I pay very attention before pushing collective to take off.
I will do it very slowly to apply little corrections when sheding.
And each time I have corrections to apply to not be in scary situations.

In your autotune manual V2, you advise to set YAW VFF to zero, and set rat yaw p and rate yaw d to values that are stable.

In my tune for the moment I followed the ardupilot manual so VFF is set to 0.025.

What I can expect if I put VFF to zero?

About filters you set all FLTE and FLTD to zero and FLTT to 20 instead of 10 originaly set following ardupilot manual. => does this can enhance the manual fine tune?

About PIDR I don’t understand… ILMI is set to zero…