Benewake TFMini - RNGFND_TYPE = 20 not in list


I’ve purchased a Benewake TFMini Lidar. I’ve updated the firmware of my quadcopter to the latest release 3.6.7 and connected the lidar to the serial 4/5 port of my pixhawk. When trying to set it up, I’ve noticed that the RNGFND_TYPE 20 is not in the list.

At the moment, the lidar is not working. In the status windows its readings are 0.

Could you please help me sorting it out?

Thanks in advance,

Looks like you need to update Mission Planner


thanks for the reply. I’m running Mission Planner version 1.3.62. It should be the latest one, right?


I’ve connected the TFMini to the PC with a USB adapter and tested it with the Benewake GUI. The sensor works. I’ve then configured it in PIX Mode with the serial commands. I’ve connected it to the PixHawk through the Serial 4/5 port but the issue still remains. The TFMini is not shown in the list of available RangeFinders.


help me. I really need this sensor…

Thanks in advance,
Alessio Buccoliero


Go to help and update to most current beta version of MP this should do the trick.


I’ve updated to the beta version of MP. Now I see Bad LiDAR Health on the Graph but still no readings in the Status Tab. Furthermore, under Optional Hardware > Range Finder now the list is completely empty. All Range Finders are gone. Tried to set to 20 in the Full Parameter List but no luck.

I’ve also tried to reinstall MP, both latest and beta versions. Range Finders list doesn’t appear anymore in both cases.

There’s something I’m doing wrong???

Very unhappy as the lidar works and it has shown as supported on the pixhawk…


anyone can give me suggestions on how to resolve this?

Thx in advance…

How the TFMINI is connected to the pixhawk ?
How the TFMINI is powered = Pixhawk or dedicated UVEC wit common ground ?
How is Mission Planner is connected to the pixhawk ?


the TFMINI is connected and powered to the PixHawk through the Serial 4/5 port. I connect to Mission Planner via USB. In attachment there are 4 photos. There are:

  • The TFMini connector
  • The serial connector
  • Mission Planner version
  • Empty list in the sonar page




Your USB port may not have enough power to operate both the pixhawk and the tftmini. Power the separately with a common ground. Or use a powered usb hub.

I’ve also tried to power it with the battery connected but the result is the same…

Have you tried exchanging your rx, tx lines in case they are reversed?

What do the rangefinder parameters look like?

What baud rate and type are you using for the serial 4 port?


I’ll try to reverse the rx/tx lines although they reflect the scheme on the pixhawk wiki (so thay should be correct). The baud rate I’m using for serial 4 is 115 (115200) and the parameters are as follows:

  • SERIAL4_PROTOCOL = 9 (Lidar)
  • SERIAL4_BAUD = 115 (115200 baud)
  • RNGFND_TYPE = 8 (Currently - Tried 20 but had same result)
  • RNGFND_MIN_CM = 30
  • RNGFND_MAX_CM = 600


ok, I’ve been running more tests. Could it be possible that the TFMini driver is not included in the firmware? There’s a way I can verify that?


I’ve rewired the sensor and it finally worked. Probably there was a loose connection with the pins.
Tried in my room and the ALT_HOLD is super consistent. I’m so happy!!

Thanks to all for the support.

The topic can be closed.