Benewake TFmini not working on kakute F7 mini

Hey guys, I setup my TFmini according the wiki, but sonarrange is still at 0. I have tried putting the TFmini wires on both the i2c ports and uart 4, and even swapped the wires when the range finder did not work. I know the range finder is receiving power because I measured the pads and the range finder is getting warm. Do you guys have any ideas?

Thanks in advance,

Good day,
what kind of tfmini you need set?

Hey David, it is a TFmini IIC. I have attached photos of the box above (my original post). I hope you can help!

Me im using the tfmini S…can you give more specs about your wiring?
As i know there are few versions of the Tfmini that you need change the add using the gui…with mine i dont need…

I have ground to ground and 5v to 5v on the flight controller, and I know it is receiving power. The green wire is connected to the SCL port, and the white wire is connected to the SDA port on the flight controller.

ok…me first time i’ve choose the serial port…after this on a can node…
for uart: 5v to 5v or (ubec), gnd -gnd , white is TX , green is RX
Did you check with benewake gui?

I did not check with Benewake GUI. How do you do that? I have also tried serial port and that does not work. I am pretty sure that my tfmini is i2c protocol.

For check it with the benewake gui tool you need a TTL board… you can find info here

What model do you have ?
What is the Rev number on the board == 1.5 or 1.8 (or other ) ?

the rev number on the board is 1.6.

The model number is l1600348010874

@rickyg32 is this the board rev you had on your TFMINI I2C?

yes thats correct Patrick
The box states I2C only.