Behavior difference between X and +

Still learning here. I got the Arducopter configured and the vehicle can take off now.
One strange thing is that it seems to me that whether I configured it to be X or + the behavior both look like a +
I double checked the parameter and the FRAME_TYPE was set as X (actually before I noticed this behavior I have never configured it as plus). However, when I tried to pitch or roll, only one corner lifts up, instead of one side (two motors) lifts up. I thought this should only happen to + frame, did I understand it correctly? I was loosely holding the vehicle and turning the TX stick on the table, and I am sure that I did not move the stick diagonally.

I am using the 4.4DEV branch that I built. I only changed the code so it would recognize my SBUX RX (see my other post about that). I don’t think it should affect this.

Anyone had any suggestions?

Are you changing the flight controller orientation to match the frame type?

Yes, I did. As I mentioned, I had never configured it to be + until I saw the strange behavior.
And after switching to + and the new orientation it worked pretty well.