Servers by jDrones

BeagleBone Blue released, Linux-enabled autopilot for 80$

hardware
linux
arduplane
arducopter
ardupilot

(Thalaivar) #167

@ppoirier What do you mean by,“set within Ardupilot”??


(ppoirier) #168

You connect locally = using USB (192.168.7.2) and launch
/home/debian/arducopter-quad -C udp:192.186.7.1:14550

Then on mission planner you can connect usind UDP @ 14550
Then you can set parameters === read the ardupilot wiki


(Thalaivar) #169

Ah right, I was attempting to do this with the 3DR radios, that would work right? As in, I run:

sudo /usr/bin/ardupilot/blue-arducopter -C /dev/ttyUSB1

on the BBBLue, and I connect to it using APM Mission Planner 2.0


(ppoirier) #170

If serial1 is not set correctly , you cannot use the radios ==This is why you have to go UDP first to gain access to parameter


(Thalaivar) #171

Thanks a million for clearing that up!


(Thalaivar) #173

Why is it that mirko’s instructions on running AP, do not work, it just says “command doesn’t exist” when I try to run:

sudo /home/debian/arducopter (plus param)

whereas this works: https://dronerai.de/blog/page/2/


(ppoirier) #174

Its all depends what you have loaded and where its loaded
Sorry but these questions are not related to ardupilot, I think you need to practice Linux a little more :wink:
BTW that looks like a really good blog


(Ben Mazin) #175

Hi all. I’m trying to get ardurover working on the BB Blue. I have the GPS and telemetry radios hooked up and working well, and I can connect with mission planner via the radio or wifi successfully.

Like others, however, I’m having trouble getting the RC receiver to connect. I’m using a Futaba R3006SB, and I’ve tried it in both s.bus and sbus2 mode. I am powering the receiver off 5V from the BBB power connector and have connected the s.bus pin the E4 pin 4. I set and verified the P8_15:

debian@beaglebone:~$ cat /sys/devices/platform/ocp/ocp:P8_15_pinmux/state
pruecapin_pu

On the oscilliscope I see a nice 3.3V digital signal coming over the s.bus pin, but ardupilot just seems to ignore it. Any ideas?

Thanks!


(Mirko Denecke) #176

@bmazin Hi Ben, are you sure that you are using pin 4? When I zoom into your pic it seems connected to pin 3? But the pic has not such high resolution, so maybe I am wrong. It is tested successful with a FrSky RX.

Regards
Mirko


(Ben Mazin) #177

Yeah, its in pin 4. Anyone successfully used a futaba s.bus receiver with the beaglebone blue?


(Tim Litvin) #178

Noob, working with pre-built blue-arduplane. I’m a year into my custom project.

In terms of frame architecture, the craft I’m building is a twin-engine delta-wing (w elevons), but specialized for a low-speed remote research application. Presently trying both Mission Planner and QGroundControl: I’ve got working GPS and telemetry reporting via 3DR 915MHz to my laptop GCS.

To reduce its energy consumption, I want to try controlling this low-speed craft using the telemetry radio via a HOTAS joystick with the GCS. I’ve gone through the joystick calibration procedure in Mission Planner and QGC, but I’ve yet to get a response from my craft’s servos or motors.

Peripherally, but perhaps informative to this problem, I took a whack at interpreting the blue-arducopter startup-on-boot instructions for blue-arduplane and tried integrating Mirko’s added instruction note regarding turning-on the servo rail, but using the systemd approach, as in the attached file.

Joystick Telemetry.pdf (300.3 KB)

It’s not clear that creating and modifying those files had any effect, but ultimately what I generated did not result in auto-startup of blue-arduplane or power to the servo pins.

Anyway, when I enable the joystick in MP and try to arm the (propeller-less) craft, I get the message that MAVlink has rejected the command. QGC reports that this control-via-telemetry is a non-default behavior, and that what I’m up against is a need for MANUAL_CONTROL support in MAVlink. Basing a search on that, I find that ArduSub has integrated this functionality, but not the other ArduPilot platforms.

Can I simply ask for this to be integrated as a regular option in blue-arduplane, or is this functionality not sufficiently general-purpose to qualify for that treatment?

Have I reached the point where in fact I do have to delve into the code base and compile my own?

I’d humbly appreciate a “road map”… or any guidance really, so I don’t waste a lot of time on this hurdle.

Thanks.


(James Pattison) #179

Missionplanner and QGC implement joystick control differently (artifact of history more than anything), so the qgc message isn’t relevant to why it isn’t working in mp.
I’ve never tried with plane, but joystick control works easily enough with copter.
You need to disable the RC prearm check, if you aren’t using rc for backup.


(Tim Litvin) #180

“You need to disable the RC prearm check, if you aren’t using rc for backup.” - Bingo. Thanks James: that could have become a huge sidetrack. Instead I’ve finally reached the point where sensors can be calibrated. IMU calibration will have to wait until tomorrow, as I’m operating shipboard today.

I’ll post the italicized sub-question about my systemd blue-arduplane-on-startup issue in a separate thread if I stuck. Guessing that’s something simple and “obvious” too.

Cheers.


(Mirko Denecke) #181

It is possible to use the standard BeagleBone Blue rcin port (DSM2) if this PR is merged in master.


(Emmanuel Carjat) #182

Hi all. I am trying to built a quad with the BB Blue. So far I have managed to get the GPS and telemetry to work. However I have a couple of questions.
I have an external Ublox Neo-M8N GPS with Compass.The compass is connected on the i2c bus and while I can see the compass on the bus and being detected by ardupilot (it’s got an ID in APM Planner) I can’t see it being used. When I turn the compass, the flight display in APM Planner doesn’t show the compass turning while when I turn the BB Blue the compass is turning. I have tried multiple settings and specifically COMPASS_PRIMARY but it doesn’t seem to take my changes into account.
Also I have read above that support for voltage monitoring was coming ( I want to monitor my main batteries via a voltage divider) Is it already available and if so on what pin ?


(ppoirier) #183

I have not tried it but if you can i2cdetect the compass on the blue, iyou should be able to use it as the external compass.
Concerning the voltage monitoring the patch are applied on code but documentation is not written yet, its a matter of getting the right code and test it, I will try to complete this soon


(Emmanuel Carjat) #184

Not only can I i2cdetect the compass but it is detected by ardupilot on startup. Here is what I get on startup:

HMC5843 found on bus 0x71E09

This is probably more an ardupilot question but would you know how I can check which compass is being used ?
Re voltage monitoring, is the patch published in the repository, if not can you share it. I am happy to test and write some documentation if that can help.


(Thalaivar) #185

I have a few questions related to the BeagleBone Blue,

Background: I want to implement my own flight control scheme on this platform and for the same I wish to write the whole controller from scratch. I however do not wish to write the HAL again myself as I am not at all equipped to do so. So my questions are as follows:

  1. How can I use just the ArduPilot Libraries to write my own code for my aircraft? I mean something along the lines of creating a runAircraft.cpp file as:

    #include “AP_Common/AP_Common.h”
    //-------------------more includes------------------//

    /--------------run some functions from AP libraries-----------------/

  2. I tried this and compiling with gcc locally on BBBlue but it throws a “file not found error”. What am I doing wrong here?

  3. I was told a RTOS is essential for a Flight Controller, is there any tutorial on how to install, implement and use an RTOS on the blue?

  4. While implementing my own Flight Control Scheme in the manner mentioned before, will I need to use RTOS?

Any help is greatly appreciated as this is stalling my project in a major way!


(James Pattison) #186

This is off topic: so short answer only.
You’re probably using an ArduPilot build file and it’s looking for things you’ve removed.


(Thalaivar) #187

Where would be the appropriate place to ask this?