Servers by jDrones

BeagleBone Blue released, Linux-enabled autopilot for 80$

hardware
linux
arduplane
arducopter
ardupilot

(Adam McBride) #142

I connected the battery first, waited for it to boot, ssh over wifi and then started ardurover-blue. From there I connect to mission planner over udp. Also, when running the rc_test_servo command it works fine and I am able to get movement.

I might add that the only things connected to bbblue are the battery and the servo, and I am trying to test the servo directly through mission planner by clicking on the low, high, toggle buttons.


(ppoirier) #143

Do you want to do this ?
http://ardupilot.org/copter/docs/common-servo.html#controlling-the-servo-as-a-servo


(Adam McBride) #144

Correct. I want to do the the last section of the document that states “Testing with the Mission Planner
The mission planner’s Flight Data screen includes a “Servo” tab on the bottom right that can be used to test that the servos are moving correctly.”

When I try it, nothing happens.


(ppoirier) #145

And you have set servo 8 function to 0 ?
http://ardupilot.org/copter/docs/parameters.html#servo8-function-servo-output-function


(Thalaivar) #146

@ppoirier I copied ArduCopter to my BBBlue via SCP, I wanted to know how I can access the files of the Copter program?


(ppoirier) #147

I am working on a new release for the Blue, that will offer more options than the actual wiki.
You can refer to the BBBMINI wki that is more detailled and show how to build the flight controler software from github.
Warning = You cannot build the blue from the bbbmini, its just for demonstration.


(Thalaivar) #148

@ppoirier My apologies but I didn’t understand what you said. Do you mean to say that I can only checkout the git code, but cannot actually modify the precompiled code I have downloaded??


(ppoirier) #149

Yes its a binary file , i.e. you cannot “decompile”.
You need to build it (preferably on a Ubuntu PC) using WAF and applying the correct build parameters.


(Adam McBride) #151

I check in the full parameter tree and it was set to 26. I set it to 0 and wrote the parameters. Tested the servo and still no luck.


(Thalaivar) #152

@ppoirier Ok right, so you build on an Ubuntu PC, then SCP the compiled file to the BBBlue? So can I put the argument as “blue” for WAF?


(ppoirier) #153

@ghostrider I will give it a try tonight , and report back


(ppoirier) #154

@Thalaivar yes thats it, you can check the FC build options with ./waf list_boards
More here: https://github.com/ArduPilot/ardupilot/blob/master/BUILD.md


(Thalaivar) #155

@ppoirier
Thanks a lot, you’re a real saviour :slight_smile:


(ppoirier) #156

@ghostrider Just tested and it works fine
I see signal change on my oscilloscope according to servo setting (low-high-toggle)
Here are servo 7 setting (they where defaulted to these values on my release)

SERVO7_FUNCTION 0
SERVO7_MAX 1900
SERVO7_MIN 1100
SERVO7_REVERSED 0
SERVO7_TRIM 1500


(Adam McBride) #157

Mine doesn’t work with the prebuilt version, but if I compile it myself and run command echo 1 > /sys/class/gpio/gpio80/value before starting ardupilot it works.

Do you run any scripts that enable the Servo rail before starting ardupilot?


(ppoirier) #158

Ahhh OK you applied my trick :slight_smile:
https://discuss.ardupilot.org/t/beaglebone-blue-based-flying-wing-do-i-have-whats-needed/20717/12

Yes power is not applied by default … sorry I overlooked that

And yes , you can copy that in /etc/rc.local
/bin/echo 1 > /sys/class/gpio/gpio80/value


(Adam McBride) #159

I did!! Is there a way to get this working by default so that new users won’t have the same problem as me? Either having it prebuilt into bbblue or doing it in mission planner or ardupilot?


(ppoirier) #160

@ghostrider Good point

@mirkix could you please add the rail power info and script on the wiki please ?


(Thalaivar) #165

I’ve been trying to connect to a GCS with the 3DR radio V2. I connected the autopilot side radio to the USB port of the BBBlue and used the appropriate port (/dev/ttyUSB1) while running ardupilot. However I am not getting a vehicle connection (using APM Planner 2.0). I can do the 3DR firmware stop perfectly fine and it updates the params on the remote perfectly. But I am not getting a connection to vehicle. How can this be solved?


(ppoirier) #166

Hello @Thalaivar , I see you are making progress :slight_smile:

So according to Mirko’s instructions : https://github.com/mirkix/ardupilotblue#run-ardupilot
If you want to connect the radio to the usb1 (and that you have a good connection working…), you have to set telemetry within ArduPilot parameter == serial correctly configured @57600 bauds using SERIAL1_BAUD and setting for Mavlink SERIAL1_PROTOCOL.

Then you then can connect by issuing:
sudo /home/debian/arducopter-quad -C /dev/ttyUSB1