Bad or No Terrain Data when arming


I`m pretty new to RC piloting so sorry in advance.

Im writing here because I have a problem while arming my Pixhawk for a RC plane. I dont have a GPS module right now, but Id like to test the servos on the ground so Im trying to arm my Pixhawk just for testing. Ive done the initial setup using a wizard on Mission Planner (accel calibration, mag calibration, Radio calibration) and Id like to arm the device. But when arming the device using a rudder + throtle arm method I get a pre-arm check error on Mission Planners top left side saying "Bad or No Terrain Data". Tried changing the ARMING_CHECK parameter value to 0, changing all flight modes to ACRO, but nothing happens just the Pixhawks LED turns from flashing yellow to flashing blue.
Any ideas what I`m encoutering and what could be the workarounds?

Thanks in advance!


Hi! Do you have the GPS connect? Are you inside home when making the test? This is not MP problem so you may need to post in the future at pixhawk sub forums.
Don’t take me wrong but if you are new at RC you are way hover the beginning of RC - servos, receiver, radio and lots and lots of glue :slight_smile:

Enviado do meu iPhone usando o Tapatalk

Well, I said that I dont have a GPS. And currently I dont need it, because I want to test my servos indoors. But I can`t arm the Pixhawk because it does not pass the arming procedures.

Sorry I miss that you don’t have GPS, well in that case you need to disable in the pre arm check you need to disable the GPS check.

Enviado do meu iPhone usando o Tapatalk

Or disable the GPS … e_gps_type

Enviado do meu iPhone usando o Tapatalk

Looks like disabling GPS parameters and disabling arming process worked (changed the parameter values to 0). Now the blue solid led shines, but thats Ok.
The other problem I got right now, is that there are no signals (no signals, no +, no -) on my Pixhawk Main Out outputs. Im powering my Pixhawk using a USB, maybe thats the problem? Do I need an external battery for this?

P.S. thanks for your suggestions!

If you need to test the AP you need to power it by the power module, … ick-start/
If you are using the usb to power the pixhawk you will not have any output to the servos

Well, looks like my problems are almost over. Thanks! Just need the battery now :slight_smile:

Unfortunatelly, the problem persists. There is no signal, no voltage in the Pixhawk main/aux outs. I`ve tried powering Pixhawk from Usb and external battery. Also, tried powering the servos externally from the 5V power supply and only providing signal from Pixhawk, but nothing happens.

Pixhawk is armed properly, no failsafe warning, the main LED is shrining blue (no gps).
What could be the problem? Cause on Mission Planner RC calibration test everything seems working, but when the servos are connected physically there is no output signal.

Any ideas?

Appart the stick arming procedure, do you turned on the safety arming switch? or have it disabled?

The switch is enabled. I hold it down and the pixhawk arms itself properly, but without the output voltage.

What I saw in Mission Planner when I armed and set up everything, that on status tab the ch1out, ch2out, ch3out, ch4out are all working properly - the values change when I toggle rudder, throttle and other joysticks.
Maybe I should simply reflash it and try to configure everything again?

I reflashed the firmware, and compared the Pixhawk parameters with a text compare tool. These are the differences between modified params and stock:

Modified Stock

Havent tested the outputs on the new firmware flash, cause need to play with gps disabling and arming procedures. Will do that tonight :slight_smile:

Did you finally tested it?

Sir same here do you any solution?
Plz tell me .
Thank you