bad optflow health

hello guys
i read almost every issues about “bad optflow health” but no solution for me.
when i connect pix4flow to computer with usb , everything is ok and it send correct data.but when i connect px4flow to pixhawk the “bad optflow health” message apeared in mission planner
i try almost everything. checking i2c port and powering px4flow Separately, also re-installing px4flow firmware several times ,not work
is there other way to check?

I have struggled with this issue. Don’t have a direct solution for you, but perhaps my experience will give you some clues. First, have you mounted the px4flow board in its permanent location, or is this “on the bench”? I concluded that it is important to this board to be oriented correctly when powered up. I had the px4flow board on the bench, connected to the pixhawk but facing up at the white ceiling, that did not work, when it was mounted correctly everything improved. (the px4flow has an IMU that should agree with the imu on the pixhawk) The second issue I see, is the order of startup. For some time the px4flow would only work if I powered the pixhawk by usb, let it startup, then apply battery power, then I would not get the bad optflow health. When I upgraded to Chibios this work around stopped working. Currently, I power the craft before turning on my transmitter. (do this at your own risk!!) This system has consistently eliminated the bad optflow health message. One last bit of advice, DON’T attempt to fly with bad optflow heath, even if your craft arms, it will go poorly for you. I hope this is of some help.

In order to work properly PX4FLOW need:

  • Rangefinder = this is NOT an option, you need a working range finder in order to get OF started
  • Good supply == dedicated UBEC
  • SDA & CLK-CLK and common grounding for all devices (FC-OF-UBEC)
  • Correct firmware (dec 2014)
  • Calibration according to wiki

If you search on this forum, you will see that , the above are pretty common… good luck

thank for reply
i have some progress. in first moment that i powered pixhawk, px4flow send data just for once and then that data not change.
i guess the problem is Rangefinder. px4flow’s own sonar are not recognize by pixhawk correctly.
i set rangefinder parameters in pixhawk as below:

i even test RNGFND_ADDR --> 42,102,112
but nothing :confused:

thank for reply friend
i set some rangefinder parameters and that message disappeared
but the new problem is data are received just for once in first moment
i am confused :confused: