Servers by jDrones

Bad logging error

Getting a bad logging error as soon as I arm copter… issue started occurring after installing sf11c range finder… could it be an issue with the SD card or something else?

Yes, the most probable cause is the SD card.

Hi Francisco,

Switched out sd card and still got some error. Decided to fly anyways ending in a violent crash. Basically I took off and it didnt seem to want to go up at 65 percent throttle and started leaning to one side. Looks like into failsafe from what I can see from the TLOG. I’m getting no GPS data from the dataflash log, but I attached both. Can you please help me figure out why this happened?

Thanks for your time7.log (213.8 KB)

Tlog does have gps data

2016-12-13 15-11-55.tlog (3.1 MB)

What board are you using?

I’m using the pixhawk 2.

Anyone have any ideas?

So… does removing the rangefinder fix the logging problem?

Sorry, but I hope not! :slight_smile:

I have suspicions about the binary file stored on the SD card. You’ve supplied a text-dump of the dataflash log; please provide the binary equivalent.

Also, the tlog covers a very large time-range, whereas 7.log is a few dozen seconds.

As to the crash itself - the craft was very annoyed with its sense of its own position and velocity. It also self-assessed its magnetometer as bad - did you fly close to something metallic towards the end of the flight?

A good dataflash log will help a lot!

Here is the binary file. The takeoff on the tlog only occurs at the very end. The reason why their are spikes in the magnetrometer is only because I was putting my phone around the compass to make sure the pixhawk 2 was using the external compass and not the internal before taking flight.

7.BIN (112 KB)

Has this vehicle flown before? Has ESC calibration been done?

This is looking very much like a motor imbalance issue:

I suspect the motor on C4 is not a happy camper.

Not sure what you’re saying, they all are sporadic… yes this vehicle flew fine w lidar the precious week. Still got the bad logging error w lidar installed, but flew fine. Upgraded GPS to droktek m8n XL before this flight only.

In the TLog you can see Failsafe was activated as soon as there was any throttle. The ThO rises while the DAlt remains the same as if it never intended to take off anyways. Am I misreading this?

Would this cause failsafe to be triggered at takeoff?[quote=“peterbarker, post:10, topic:13424, full:true”]
Has this vehicle flown before? Has ESC calibration been done?

This is looking very much like a motor imbalance issue:

I suspect the motor on C4 is not a happy camper.
[/quote]

Tried multiple SD cards with same error. Could this be dangerous to fly with? Any ideas?

Ben

Hi, did you got any solution. I’m on the same point…

Same problem to me, plz guide if you have found any solution.

I am troubleshooting the same issue. Been chasing a bad logging message for months.

Swapped the SD card numerous times
Swapped the pixhawk
changed the buffer size
checked VCC to ensure within tolerance.
check PM.LOG messages - no dropped.
No hard resets.
card is formatted to FAT32

I have no idea what is causing the problem. Until I fixed it my drone is unuseable. I need to log files to GEO tag images.

Sucks

I believe I just flashed the firmware and the message went away. Also,
when I had the issue (this was quite some time ago), I was told it wasn’t
dangerous to fly with by deva.

Ben

It’s definitly not dangerous, but you can’t GEO tag images without a log file. The log file contains the data required for GEO tagging.

I’ve changed the entire flight controller and swapped the SD card numerous times, so its something with my set up or parameters.

Have you tried reflashing firmware? Load another firmware and then reload
your desired firmware.

Servers by jDrones