Bad behaviour in navigation mode

Hello, I build a custom drone for mapping and survey with following parts
700mm carbon fiber frame.
adti camera
16x5.5 propeller
orangecube plus
16800mah lion battery
Hobbywing xrotor pro 40A esc
380kv antigravity t motor.
Arducopter 4.4.2 firmware version
MTOW= 3530grams.
Dual gps configuration, Here3 Gps and emlid reach m2 ppk .

I have done autotune for all the 3 axis and everything went well, once I start testing the drone in althold, loiter, stabilise and positionhold modes its working fine. But when I planned a mission, while in a mission drone behaviour is not stable and it is not following the path. while in yaw observed wobbling ,later manually tuned it to make stable. I didnot get why it is not stable in auto mode and RTL mode. Once I hit RTL command there a more delay in taking and RTL loiter time I set as 2sec but still its taking 20sec RTL hover to desend and if bad battery even though I configured parameters to RTL its not taking. I have attached a log below please have a look.

1 Like

Autotune is not a solution for all problems. Before you can do a proper autotune there are lots of configuration steps that you must do. And after autotune there are also a lot of steps you must do.

Have you done them?

1 Like

@amilcarlucas Thank you for your response, till now I have tuned more than 10 drones with different categories and I did not notice this type of behaviour and yes usually will follow whatever you shared before tuning. Even after tuning the same drone for 3 times this issue could not solved. As I am using TF02 pro lidar is that causing any issue? Also in auto mission it should follow the path but in this case it is not and if we hit RTL there is delay for taking command and returning to home. Any other solutions for it?

Test without the TF02. And follow the instructions I posted. Including using some of the files in the .zip file.

I have followed the instructions whatever is mentioned but no changes, now I will try by disabling TF02 .

Update to ArduCopter 4.4.4

Do a basic flight with these set:


because I suspect the harmonic notch filter could be better, then you’ll be able to work on the rest of the tuning.
It’s OK to leave them set too, no burning need to turn them off.

I have done more than 2 times to set harmonic notch filters and notch filters are applied to those frequency which is at peak. Should I do one more time and check? and how come harmonic filters only effect in auto and RTL whereas rest all modes are working well and good.

Because the tuning overall is not ideal, there can be much improvement yet.

May I know in which axis the tuning has to be improved?

Just pitch and roll and yaw, that’s all :slight_smile:

They are not too bad, but could be a lot better.
If you ran autotune and it resulted in this, then probably noise was an issue - which leads me to believe the harmonc notch filter is not quite right.

Sure than I will redo the harmonic notch filter and fly the auto mission.

No, just do an ordinary flight with some pitch, roll and yaw, throw in some ascents and descents.
Use AltHold and Loiter in the same flight.
Let’s see that log.

Move on to Auto later after all the tuning is sorted out.

Once more thing to mention as we are expecting 1 hour of endurance with the drone but in auto mission, drone is consuming more current which is making us to acheive 30 to 35 mins max. is there any suggestion to improve flight time?

Tuning will help a bit, but lets see more data from logs.

In the log I looked at, the motor outputs are up around 1600 to 1700 PWM, which indicates you are trending towards overweight/underpowered.

Often people believe the manufactures recommendations for motors and props, and those recommendations are not always right.
ecalc gives you a better idea of what components work together and what sort of performance you can expect.

dont rename your logs either, just keep them with the normal date and time format.

I do have another drone with MTOW 5.5kg and having a motor output around 1700 to 1850 PWM but still it is giving a endurance of 60 mins. Is there anything we have to look?

yes we calculated endurance using ecal, whereas it showed 26mins of endurance but we achevied 35mins, but we are expecting 50mins atleast.

Yes some motors operate well in that range, at first glance it looks like they could be stressed, but they work well anyway.

Genuine question: what makes you think you should get 50 minutes flight time?

Earlier with MTOW 4kg same frame but 500g more with same propulsion system we got 50 mins of endurance. Tuning has been done well. but now we reduced 500g in frame and testing in 4.4 FW this time we are facing lots of issues, particularly in navigation and RTL. I am attaching the log below of which we tuned for 50 mins of endurance.

Yesterday I have applied harmonic notch filter and have done autotune but there is no changes in navigation and RTL mode, observed the same issue poor performance in navigation mode and RTL. I am suspecting on firware version might be not supporting for my frame.

Looking at log TTA2
There is a very large instability when descending.

Assuming this is the copter with the Hobbywing Xrotor Pro ESC’s…
I would do the semi-automatic ESC calibration first:

Then set


and use MissionPlanner motor test to check and adjust the MOT_SPIN_ARM and MOT_SPIN_MIN
Get MOT_SPIN_ARM to be as low as possible, but just enough for all motors to start reliably. Set MOT_SPIN_MIN +0.03 higher.
In the next flight (discussed below) the hover thrust will need to relearn.

Set these and leave them set this way:


Like I said, I suspect you harmonic notch filter is a bit wrong and we could improve it.
The frequency should be up around 50Hz to 60Hz for those props - 28Hz is about half of that so I’m interested to see what’s going on.
Also the INS_HNTCH_FM_RAT should be 0.7 and INS_HNTCH_REF could be a fraction lower - but we will know more after the next test flight.

The PIDs look extremely low - I would start with these, they are not too far different from what you have now so should be safe:


For the next test flight, just take off in AltHold, do some gentle pitch, roll, yaw, ascents and descents - then do the same again in Loiter mode, then just land. Dont try to do Auto missions or anything fancy.

Let’s see that log, and we should find more settings to adjust.