Autotune plane: need help > desired Roll and achieved Roll


I have a Volantex Ranger 1600 and Dart 250g.
On the 2 planes, I have the same behaviour in autotune.
Autotune Level is set to 7 on Dart 250 and 6 on Ranger 1600.
Volantex run on 3s2p li-ion and Dart 250 on 2s1p li-ion.

Ranger 1600 use Matek F405-wing and Dart 250 use Matek H743-slim.

I’m running Yaapu version with CRSF on the 2 planes with DJI FPV Goggle.

As soon as autotune start and I roll back and forth, the achieved roll decrease strongly.

Please, I need help to know what are the parameters I must changer to have a better adequation of this 2 values. I’m a long user of arduplane but never really found how to tune correctly my planes.

I post the log here of the Volantex 1600 40 min flight and the MP parameters.

The video of Volantex 1600 flight is here with autotune session if could help.

I have the exact same behavior with Dart 250 and could send them if anyone interested.

I really appreciate if someone could give some hints on what are are the steps to achieve in order to have a well tune aircraft.

kinds regards,


the firmware you’re running is quite old, it is from well before we introduced the new autotune system and even has the old PID system.
I’d suggest updating to 4.1.0beta3 and try again. You may also prefer AUTOTUNE_LEVEL=8.
Please do post logs of your testing of the new autotune as I’m looking for logs on a wide range of aircraft to help improve the algorithm.

Thanks Tridge. I will do that and test in next low wind condition. I will do this on Volantex Ranger 1600 and Dart250g.

@tridge I installed last beta firmware on Dart250g (weigth 285g with DJI nebula Pro cf my part here and it’s clear that autotune works nicely now. Like you suggest, I use AUTOTUNE_LEVEL = 8, starting with default PID value (I find annoying there isn’t an option when flash firmware to reset PID so I hade to wipe it first then manully upload some parameter with ‘compare mode’ in full parameters menu of Mission Planner) . I hade some gust till 9m/s and with a small plane like this, it’s amazing. I made 2 flights of 25 min anf I’m pretty happy now. Because I fly with CRSF and DJI Digital, I didnt’ have the OSD on video record. I try to use Dashware but DJI video format is not recognized. Here the log of the flight with Autotune: Here the video of this flight:
Next flights, I will do it on Ranger 1600. Thanks for advice to upgrade firmware !

@Tridge: I post the wrong log file. Log with Autotune is this one: . The log I posted previously is the flight after autotune.

Just to be clear, are the new PID system and the new Autotune both in 4.1.0 beta but not in dev? Because I can’t find the new PID parameters on my installations, not even on a never-flown, freshly installed one.

I updated to ArduPlane V4.1.0beta4 (3de5ca6e) and I done the new autotune with ‘autotune_level=7’ and I’m more than happy with results. I flown 3 time since Autotune and for the first time, autotune gave me a really really amazing flying characteristics in fews seconds on a so tiny Dart 250 with 285g … Thanks @tridge and ardupilot team. :grinning:

@tridge: I could send you the 3 logs flights in MP if you need them.


logs would be good if you don’t mind - it is good to have some logs of smaller planes

I send you LOGS by MP directly with videos.
(nb: wind direction was going ~from sunset)