Autotune pausing please help

My rig:
Pixhawk cube with Arducopter 3.6.10 on ChibiOS
Custom H 450mm frame
KDE Direct 2315XF motors (4)
APC 9.5x5 props
Kiss Race 24a ESC
5200mAh Tattu battery

I am very new to arducopter , its my first build with the software. As I muddle my way through the learning process I am getting stumped on the autotune feature.
The autotune seems to start off ok, but then pauses until I make a pitch roll command. I tried upping the dead zones to ch1,2 & 4 from defaults to 100 without a change. Is there something I may be missing, something wrong with my build? Not sure where to go, so I am asking for some help.
Attached is a bin file for review.
Bin file

looks like you built a very nice copter. I would like to see a picture for reference.
The only thing I can think of is a TX trim not being centered.

The autotune is working:

(Don’t worry about understanding this crazy graph, just know that it’s doing its thing)

That said, autotune does pause every time you move the sticks, which was happening often on this flight. Was it windy? Its easier to do on a still day. Another thing that could help is invoking Autotune from Loiter or PosHold modes, which will automatically keep the drone within a 10 meter radius.

Also, it might be a good idea to tune one axis at a time, depending on your battery endurance. You can do this by setting the parameter AUTOTUNE_AXES to 1 for roll only, 2 for pitch, and 4 for yaw.

Also, I noted the following:

  • Your throttle and roll RC channels are flipped. Not a bad thing, just wanted to mention that it’s unusual since you said you’re new to ardupilot.
  • The copter has pretty severe roll oscillations. Autotune will handle this, but you might want to start by lowering your rate roll P value to make the autotune flight less scary.

    This is roll angle (red) and the rate controller’s roll output. You can see that the controller is constantly overshooting, resulting in oscillation.
1 Like

Thanks for complement, I’ll post a picture soon.

Thank you for the abundant info. I will get to work using your suggestions.

When the log was created there was not a breath of wind. I tried posHold a few days back but I couldn’t get a good GPS signal (too many trees). I’ll give posHold another go and get back with the results.

Concerning your notes, (I really appreciate these):
The throttle and RC channels were flipped because when doing the initial setup,Radio Calibration, my spektrum DX8 throttle movement(left stick) showed movement on the Roll Bar, and Roll movement (Right stick) showed movement on the pitch Bar. The Pitch movement (right stick) showed movement on the throttle Bar. The only thing correct was Yaw. I must have changed the mapping at some point to make stick movement pair with the bar movements. So its back to investigating whats going on there…Like I said I’m pretty new to Ardupilot. I goobered things up so bad that when it sorta worked I ran with it.

On another note, I would be interested in learning how to use the log for diagnostics, do you have any suggestions on where to start?

Thanks a bunch!

Here ya go, its a custom H frame:
AUW 1727g
Carbon Fiber plates
Aluminum ARMS from a QAV 500
Custom Gimbal housing 3d Printed Min3D PRO gimbal
It is still in the build phase some components are temp mounted for testing only.


Start here:
The documentation is a bit old at this point, so some things may look a bit different, but it is still relevant.

Yeah, you have the option of either changing the channel mapping in ArduCopter, or on the transmitter itself. Both will work just fine.