AutoTune not working at Copter 3.6.10

Hi guys. Few weeks ago I made an AutoTune Procedure in all three axes of my QuadCopter X with Copter 3.6.9 and it worked perfectly.

Now I tried the same procedure (but now only calibrating Roll and Pitch) in Copter 3.6.10 with the same UAV and it did not work. The vehicle did not made the moves as expected and did not show any error messages at Mission Planner. Is there any parameter or issue that put limits in the moves while on AutoTune mode? I suspect it is my LOG_BITMASK parameter that I had enabled more data than the Default package, but I can not confirm it.

EDIT: The UAV does not move as it was in AutoTune procedure when I put the switch ON in my RC, but Mission Planner shows the AutoTune Flight Mode. When we move the roll/pitch stick in RC, it makes a aggresive move for one side as it was doing the procedure, but does not continue the calibration movements.

Any guesses?

Link to my log:


I have not had a chance to look at the logs, but make sure your throttle is centered. Made this mistake a bunch of times myself. I just recently auto-tuned a Hexa with 3.6.10 and it went perfectly.


Rich, I had just flied with doubled values for the 4 main RC Inputs Dead Zone and it did not made difference. I paid attention and my throttle was centered, and again the UAV behavior was strange.

I haven’t attempted an AutoTune from AltHold since ages…

Did you start with default PIDs or with the ones from previous autotune?
Sometimes a too high PID value can prevent autotune from performing…

yes as @Eosbandi said try with default PIDs
in your log you can find autotune messages but no movement

Ha! Cornel - same! Remember waiting for a nearly perfect calm day to run Auto_tune? Don’t miss that at all.

I have noticed that when auto-tune completes it ignores the fact that I am in PositionHold and will drift as in AltHold.

You are correct. In hindsight, I noticed myself that drift at the end of AutoTune, but only because I didn’t hear the FC buzzer signalling it, once or twice, and had to wait for the flood of status messages to my Yaapu telemetry to end and get the “autotune successful” broadcast.
I usually hear the buzzer, switch back and forth to Loiter, test the new params and come for a land and save.
I’ll do one tomorrow and wait longer.
[LE] And I’ll also wait longer in Loiter before engaging AutoTune, because that’s the state it’s supposed to revert to after - Loiter with original PIDs.

The drift is expected - have a look at the wiki

@Eosbandi yeah, I am using the default PID values.

@hosein_gh, how did you get this nice view about the AutoTune proccess? Using Mission Planner or another tool?

@wn0x @andyp1per @ThePara Do you guys think it will make any difference to run AutoTune from Loiter instead of running it from AltHold? My UAV was drifting a little during AutoTune process from AltHold because my town always have a little wind this season.

Loiter and PosHold work great for me for AutoTune when it’s windy

I used APM planner

@hosein_gh @andyp1per @Eosbandi @ThePara @wn0x Guys, after messing up with many parameters, finally I had discovered what was wrong with AutoTune. When I first fly this drone, I followed the Tuning Process Instructions in
After reading it again, I saw something that intrigued me:
"There a number of problems that can prevent Autotune from providing a good tune. Some of the reason autotune can fail are:

High levels of gyro noise."

I checked the INS_GYRO_FILTER parameter and it was set to 40, the recommended value for 10 inch props. Then I set this parameter back to its default value of 20 (and consequently halved the ATC_RAT_PIT_FILT and ATC_RAT_RLL_FILT following tuning instructions), and now AutoTune works perfectly.

Two little questions: Is there any Log Channel that I can monitor to see if there are high levels of gyro noise? This can be only vibration issues in my frame or maybe a wrong instruction in the wiki page?

1 Like

Do you know if there is any way to recover the last discovered gains in the datalogs after an aborted AutoTune? It successfuly calibrated Roll and Pitch, but my batteries ran into Failsafe during Yaw Calibration.