AUTOTUNE help and advice for 47" 67kg quad

Hello everyone. We have made such a big drone for carrying heavy payload to the higher point at the urban districts. We have tried it with dji A3 flight controller, it flies good with A3. But we need fully autonomous flight, so we have bought CUAV x7 pro and Neo 3 GPS Module. Now we need help for tune this little baby for good flight with x7 pro Controller. I have some experience with autotune, but haven’t done with such a big 220 sm and 67 kg drone. My max size have been 100 sm (dji s1000).

As usual this drone didn’t fly with stock pids. I played manualy with pids a little bit and then it took off. At the moment i only can fly several meters above with little stick inputs at STABILIZE mode but have’t try Althold and Loiter. I have read Tuning Process Instructions and AutoTune from the but real experience always can be different. So prio AutoTune what settings i must exactly change for this little 67kg drone? such as filter settings and other settings. I need your help and experience. We dont want to crash our dreamliner :slight_smile:

our setup is this:
220 sm custom made carbon frame and carbon arms
T-motor U15L kv43
T-motor 300A esc
T-motor 47x18 propeller
24S 44000 mah lipo battery
AUW with battery and without payload: 67 kg

1 Like

Do all the steps in the documentation and post a .bin file with LOG_DISARMED = 1 before doing the first flight

how can i post that bin file to the flight controller?

Use something like

We have done autotune with stock parameters, without any changes in gyro and accelerometer filters. We only changed aggressiveness from 0.05 to 0.07. The result is not bad for this heavy guy. Roll and pitch is good but we have a big problem with yaw. When we give a little bit fast stick movement to the drone and release stick, it behaviors as in the video. It oscillates several times and stops, as if wants to fall but doest fall.


This is our pids after all axis autotune.

As the frame is symmetric I have put roll’s pids to the pitch.

Why our drone ossilate in the fast yaw input? I also tried some filter changes but didnt help.

I changed:
ATC_RAT_YAW_FLTE to 2 (default was 1)
ATC_RAT_YAW_FLTT to 10 (default was 20)
but could’t notice any difference.

Then we tested our drone with DJI A3 flight controller. The yaw is solid we A3 without any oscillations. So I thinks this is not esc or motor side problem. This is pid side problem of Cuav X7. The problem is still actual. Please help us to solve this problem :pensive:

Try setting the “Rate Yaw” P and I values to 1 and 0.1 or even lower, 0.8 and 0.08
but without the .bin log file it’s hard to tell anything.

Did you do all the initial parameters and follow the tuning guide?
If you update MissionPlanner the Initial Parameters are now in the Setup tab with mandatory items and similar. You would be able to accept everything it offers except the “ACCEL MA” values shown in your pic if they were derived by Autotune. Those parameters are really called ATC_ACCEL_x_MAX for Pitch, Roll and Yaw.
Your ESCs may require the T-Motor Flame settings, you are probably already are using them:
MOT_THST_EXPO,0.2 up to 0.4

Also set INS_LOG_BAT_MASK,1 to gather data for setting up the Harmonic Notch Filter.