67KG heavy quadcopter oscillate in loiter - PLEASE HELP US

Hello everyone. 3 weeks ago I had posted thread about AUTOTUNE help and advice for 47" 67kg quad. We did auto tune with 0.07 aggressiveness for roll, pitch and 0.1 for yaw without any problem.


At first time we had stability problem during yaw command related for MOT_THST_EXPO 0.65


With the help of Nikolay (bryashko) we calculated expo value and got 0.25. With 0.25 expo value yaw problem WAS SOLVED. Now the copter flies good in stab, althold modes. In the loiter it flies good in the windless condition. But in the windy condition it begins ossilate when changing to loiter. Here is vidoe:

After 2 days we are going to the field to test some parameters again. Nikolay says this problem can be from Rate P and Rate D gain values. I have to play them manualy to eliminate oscillation in the loiter mode at windy condition. Who has any other suggestions for testing in the field?
I aslo played a little bit with Position XY an Velocity XY pids in windy day but nothing changed.

Our parameters:

Logs windless day

Logs windy day:
flight No 1
flight No 2, No 3 and No 4

Current PID

our setup is:
CUAV x7pro with Neo 3 proCurrent PID
220 sm custom made carbon frame and carbon arms
T-motor U15L kv43
T-motor 300A esc
T-motor 47x18 propeller
24S 44000 mah lipo battery
AUW with battery and without payload: 67 kg

You need to set up the harmonic notch

Forum users are helpful and friendly, and you will sure get some great advice on fixing it.
This vehicle is not a DIY category. If you rely only on the community to support your business, you will eventually fail. If you can buy components for a copter that motors and ESC’s cost more than 10K, you can pay for some professional help or become an ardupilot partner. So recommend to do one of these things, there are many good freelancers (Commercial Support — ArduPilot documentation), or if you become an ardupilot partner (ArduPilot Partners Program — ArduPilot documentation), you can get help directly.

1 Like

I don’t quite trust T-Motor ESCs. I’ve experienced myself and heard of horrenduous results with Flame ESCs. One or two wannabe businesses failed before my eyes after countless expensive T-motor carbon props, part of “manufacturer combo”'s impacted ground. Mind you, the 60A Alpha HV does a decent job with 24-inch on 12S, but that’s about how large a prop I’d trust to a T-motor ESC.
You can try the following:

  • add some weight, so you hover at higher RPM. In brushless realm, higher RPM reduces the torque needed to accelerate or decelerate the propeller.
  • under-prop. Use a smaller propeller, that needs less torque. Don’t know what’s available for your mount. Both this and the above will reduce efficiency, but at least it can fly in windy weather.
  • change the ESCs. Not too many choices on the horizon, but I’ve heard APD has some interesting lineup.

1- Change the GPS stand as in the picture.
Try to set the filter settings as in the EXcel file. very high
2-PID settings seem too high to me. Lower the P and I values to 0.10, not 0.16. Step by step.
3- First, lower the D value to 0.0046. If there is no problem, then lower it to 0.0036.

Initial parameters.zip (8.3 KB)

That’s an older copy of that spreadsheet. Here’s a more up to date version
It’s also available in MissionPlanner by pressing Alt A and now also in the Setup page


Thank You very much. Useful information

@Ferid_Hemidli I have seen your videos and log files and I kindly like the way you provide information to the community for getting help: clear video with status and the right log files.

Here are something I could realise when examing you logs. I do not have much experience like the rest but by tuning 42kgs and lighter weight classes, I always check these information:

The vibration:

This looks bad to me. Anything higher than 30m/s/s should be concerned. I am guessing you are using some kind of autopilots that have more than one IMU inside and 2 of them are mounted in the foam (isolator, damper…) This damping mechanism may work in higher frequency drone (lighter drones) but not yours (and mine). So the damper may amplify the vibration caused by propellers or by resonance. I suggest:

  • Changing the primary IMU (copter 4.1 may have this features) to the third one (maybe it is the one with hard mounted)
  • Or, disable 2 first IMUs
  • Perharps you want to add extras damper of the autopilot. Use silicone balls or things people used in camera damper.

Current attitude:

It seems to me the drones could never be at the level state because roll is bias:

This happened in pitch but less


Motor 4 rotated a bit higher than the rest

My 2 cents and hope this helps.

1 Like

Biggboy is right, you have a problem with vibration on imu0 and imu1.
Imu2 is better, but not really good.
Imu1 is clipping 1160 times in 33 minutes.

you need to fix that problem first!

1 Like

To get the vibrations down you can use softer rubber dampers or use less (4 not 6).
Or add some weight to your FlightController-Plate, for example 50 or 100g.
you can check your vibrations in the field in MissionPlanner:


1 Like