Servers by jDrones

Auto Takeoff and Reverse Thrust not working after upgrading from 3.7 to 3.8


(Igor Campos) #1

Hello everybody,

I was using the PIXHAWK 1 on a RVJET on Arduplane 3.7, it was working great, I decided to use reverse thrust as the RVJET has a very good gliding ratio and I was having trouble landing in small areas. I configured it successfully (including an SF11/C) and was landing well, probably up to 30 m past the target point.

I read the release notes for the version 3.8 and saw that one of the things it provided was increased landing accuracy, so I decided to give it a shot, however, after the upgrade it stopped performing auto-takeoffs and using reverse thrust at landings. (I found a similar topic: https://discuss.ardupilot.org/t/tkoff-thr-minacc-and-tkoff-thr-delay-doesnt-work-together/19928, but decided to start this new one as I’ve also noticed it affecting the reverse thrust and I can’t confirm yet if changing one of TKOFF_THR_MINACC or TKOFF_THR_DELAY will correct the issue).

I followed the upgrade guide (had to adjust elevon settings) and it did not have anything specific on these matters, but I even checked the parameters and did not find anything that could be the cause of this problem. On the GCS it even said the acceleration and waiting time to arm, but it did not arm (at least it did not spin the motor).

I tried several takeoffs and it spun the motor on one instance, but according to the log it was after triggering the next waypoint (loiter_to_alt):

On the other successful takeoff I switched to FBWA as it didn’t arm, gained speed and height and then switched back to auto mode.

In neither of the landings did it use reverse thrust and went well beyond the target point (about 120m).

I uploaded the logs to my google drive, they can be seen at:

https://drive.google.com/drive/folders/0B-7Na4cfma4RaUx1N2czTW9vWG8?usp=sharing

Please let me know if the tlogs can be of any use, but I think the BINs are better.

Thank you all in advance for your attention and help!

Sincerely,

Igor Campos


TKOFF_THR_MINACC and TKOFF_THR_DELAY doesn't work together
(Kikislater) #2

About reverse thrust on AP3.8, did you watch this post ?
https://discuss.ardupilot.org/t/arduplane-reverse-thrust-setup/18324/3


(Igor Campos) #3

I followed the guide and it was working successful on 3.7, my parameters are:

USE_REV_THRUST = 2 (Landing only)
THR_MIN = -100

To avoid issues on Manual mode I set my RC to send only values between 1500 and 2000 to the FC. This way I can’t reverse thrust in Manual, which could cause a disaster.

Thank you for your contribution!


(Kikislater) #4

And is it working with 3.8 ?


(Igor Campos) #5

No, it is not, neither reverse thrust nor auto takeoff.


(Kikislater) #6

Hi,
I founded something interesting about reverse thrust. Parameters has changed on this page :
http://ardupilot.org/plane/docs/parameters.html#use-rev-thrust-bitmask-for-when-to-allow-negative-reverse-thrust

Before november 2016 it was like that :

So using reverse thrust for landing is 2

And after november 2016, may be related to AP 3.7.1, it is like that :

Mission planner 1.3.49 display informations on the first screenshot like fbwb : 512.

Should we now consider Bitmask or values to enter, that is the question !


(juvinski) #7

Hi @kikislater

the documentation is not right, on version 3.7.1 and 3.8 the definition is:
enum {
USE_REVERSE_THRUST_NEVER = 0,
USE_REVERSE_THRUST_AUTO_ALWAYS = (1<<0),
USE_REVERSE_THRUST_AUTO_LAND_APPROACH = (1<<1),
USE_REVERSE_THRUST_AUTO_LOITER_TO_ALT = (1<<2),
USE_REVERSE_THRUST_AUTO_LOITER_ALL = (1<<3),
USE_REVERSE_THRUST_AUTO_WAYPOINT = (1<<4),
USE_REVERSE_THRUST_LOITER = (1<<5),
USE_REVERSE_THRUST_RTL = (1<<6),
USE_REVERSE_THRUST_CIRCLE = (1<<7),
USE_REVERSE_THRUST_CRUISE = (1<<8),
USE_REVERSE_THRUST_FBWB = (1<<9),
USE_REVERSE_THRUST_GUIDED = (1<<10),
};
the bitwise for 1<<1 = 2


(Kikislater) #8

I’ve got a successfull working params for reverse thrust on AP 3.6 :

I will try tomorrow on 3.8. But why values were removed from documentation ?


(juvinski) #9

Nice landings :slight_smile:
I mean not removed just was changed between 3.6 and 3.7.


(Pompe Cukor) #10

So do we need to set “2” now for only landing approach (only)?
The arduplane doc is not updated. I have “1” set now and it is using reverse in auto always. I was just about to post asking why.


(MagicRuB) #11

Hi all. These docs and functionality have not changed since the initial release. However, the docs could use some better explaining. I chatted with @tridge with it and he will re-explain it on the wiki. Stay tuned!


(MagicRuB) #12

The wiki should now say:
“This controls when to use reverse thrust. If set to zero then reverse thrust is never used. If set to a non-zero value then the bits correspond to flight stages where reverse thrust may be used. Note that reverse thrust is only ever auto-enabled in auto-throttle modes. In modes where throttle control is pilot controlled the ability to do reverse thrust is controlled by throttle stick input. The most commonly used value for USE_REV_THRUST is 2, which means AUTO_LAND only. That enables reverse thrust in the landing stage of AUTO mode. Another common choice is 1, which means to use reverse thrust in all auto flight stages.”


FBWA mode executes full throttle instead of reverse thrust
(Kikislater) #13

Thank you MagicRuB, it’s more evident now.
Ready to test tomorrow :smiley:


(Kikislater) #14

Works well with me. Thank you MagicRuB and Tridge. Reverse thrust is amazing. Without rangefinder or lidar.


(Pompe Cukor) #15

Thank you for these details. Takes out the guess work :slight_smile: Was wasting a lot of energy on loiter to alts, before this.