Servers by jDrones

Auto Mission not Continuing After Package Place Command


(Seth Poh) #1

Hi all,

I was trying out the package place command in an auto mission. Basically my mission goes like this:

Take off -> Waypoint 1 -> Package place at waypoint 2 -> Waypoint 3 -> RTL

The default attitude was set to 5 m and the max descend for package place was set to 2 m.

What happened was after waypoint 1 the aircraft flew to waypoint 2 but did not proceed to waypoint 3. It just hovered at 5 m altitude without descending. I waited for a full minute before I needed to land the aircraft

I intended this flight to be only a test, so no payload was attached to the aircraft and no gripper servo was defined. I was wondering whether it was due to these reasons that I had the above mentioned issue.

Anyone here has seen this problem before?

Thank you.


(rmackay9) #2

Hi Seth,

Any chance to get a dataflash log? It’s all guesswork without a log.


(Seth Poh) #3

Hi Randy,

The log can be found here:

Thanks for looking into it.


(Seth Poh) #4

Hi all,

Just some update about the issue in case anyone is having the same issue. To simplify the troubleshooting, I have simplified the mission to:

Take off -> Package place -> RTL

Default relative altitude and max descend for package place remains unchanged at 5m and 2m respectively.

This time round I have defined AUX 5 as EPM by doing the following: brd-pwm-count -> 6, RELAY_PIN-> -1, and SERVO13 -> 28 (EPM, no gripper option available). Similarly, parameters with GRIP_X are not available in 3.6 copter.

The result of the test flight remains unchanged. The aircraft just hovered over the location where the package place was supposed to happen without descending and the mission did not continue to the next command.


(rmackay9) #5

Hi @seth_poh,

Txs for the report and the logs. I think that @peterbarker is going to have a look at this…


(peterbarker) #6

I’m looking at this today.

Interestingly, the tests created for this seem to be passing (https://github.com/ArduPilot/ardupilot/pull/9784), so a little more digging is going to be required!


(peterbarker) #7

OK. This seems to be working as expected for me.

pbarker@bluebottle:~/rc/ardupilot(khancyr-precland-autotest)$ mavlogdump.py --t MSG logs/00000003.BIN 
2018-11-15 14:08:20.26: MSG {TimeUS : 94281439, Message : ArduCopter V3.7.0-dev (d1990e6d)}
2018-11-15 14:08:20.26: MSG {TimeUS : 94281439, Message : New mission}
2018-11-15 14:08:20.26: MSG {TimeUS : 94281439, Message : Frame: QUAD}
2018-11-15 14:08:20.26: MSG {TimeUS : 94281439, Message : GPS 1: detected as u-blox at 115200 baud}
2018-11-15 14:08:42.99: MSG {TimeUS : 117015675, Message : EKF2 IMU0 in-flight yaw alignment complete}
2018-11-15 14:08:42.99: MSG {TimeUS : 117015675, Message : EKF2 IMU1 in-flight yaw alignment complete}
2018-11-15 14:08:48.31: MSG {TimeUS : 122336046, Message : Reached command #2}
2018-11-15 14:09:01.01: MSG {TimeUS : 135035964, Message : hover throttle delta: 0.012875}
2018-11-15 14:09:05.71: MSG {TimeUS : 139735750, Message : Reached maximum descent}
2018-11-15 14:09:28.35: MSG {TimeUS : 162375857, Message : Reached command #4}
2018-11-15 14:10:18.09: MSG {TimeUS : 212115953, Message : Disarming motors}
pbarker@bluebottle:~/rc/ardupilot(khancyr-precland-autotest)$ 

Here’s what I did:

pbarker@bluebottle:~/rc/ardupilot(khancyr-precland-autotest)$ cd /tmp
pbarker@bluebottle:/tmp$ mavmission.py 2018-11-09\ 00-40-27.bin 
Saved 6 waypoints to mission.txt
pbarker@bluebottle:/tmp$ cd -
/home/pbarker/rc/ardupilot
pbarker@bluebottle:~/rc/ardupilot(khancyr-precland-autotest)$ ./Tools/autotest/sim_vehicle.py --gdb --debug -v ArduCopter -l 1.2983170748,103.7793502808,0,0 -w

And in MAVProxy:

param set DISARM_DELAY 0
param set SIM_SPEEDUP 10
wp load /tmp/mission.txt
arm throttle
mode auto
rc 3 1600

And then graphed:

pbarker@bluebottle:~/rc/ardupilot(khancyr-precland-autotest)$ MAVExplorer.py logs/00000003.BIN 
MAV> graph POS.RelHomeAlt MSG.Message

pbarker@bluebottle:~/rc/ardupilot(khancyr-precland-autotest)$ cat /tmp/mission.txt 
QGC WPL 110
0	0	3	16	0.0000000000	0.0000000000	0.0000000000	0.0000000000	1.2985633612	103.7796554565	17.6000003815	1
1	0	3	22	0.0000000000	0.0000000000	0.0000000000	0.0000000000	0.0000000000	0.0000000000	5.0000000000	1
2	0	3	16	5.0000000000	0.0000000000	0.0000000000	0.0000000000	1.2983170748	103.7793502808	5.0000000000	1
3	0	3	94	2.0000000000	0.0000000000	0.0000000000	0.0000000000	1.2981100082	103.7795562744	5.0000000000	1
4	0	3	16	5.0000000000	0.0000000000	0.0000000000	0.0000000000	1.2983109951	103.7797393799	5.0000000000	1
5	0	3	20	0.0000000000	0.0000000000	0.0000000000	0.0000000000	0.0000000000	0.0000000000	0.0000000000	1
pbarker@bluebottle:~/rc/ardupilot(khancyr-precland-autotest)$ 

(rmackay9) #8

@seth_poh,

I see that there’s no RTL at the end of the mission. When a mission ends without an RTL at the end the vehicle will just sit there. Could you maybe try adding an RTL at the end and trying again?


(Seth Poh) #9

Hi @rmackay9 , I assume you are referring to the log of the actual flight rather than the uploaded mission? The mission I uploaded can be found here -

It did contain another waypoint after the package place followed by a RTL. This was verified by reading back the waypoints from the Pixhawk. @peterbarker also retrieved the same mission from the log. During the mission the vehicle got to the waypoint for the package place and just hovered and did not proceed to the next command in the mission. I switched to loiter and piloted the vehicle back to launch.

@peterbarker - I am quite convinced the mission uploaded was fine given it was just six instructions long and that the Package Place codes work. Maybe it was just down to how I flight tested with no payload or how the gripper was defined?

On a unrelated note I was running 3.6 Copter for this flight. I have just upgraded to 3.6.1 Copter ChibiOS with no change to this behavior during test flights.

Thank you for both your help in looking through the log.


(peterbarker) #10

It did contain another waypoint after the package place followed by a RTL.
This was verified by reading back the waypoints from the Pixhawk.
@peterbarker also retrieved the same mission from the log. During the
mission the vehicle got to the waypoint for the package place and just
hovered and did not proceed to the next command in the mission. I switched
to loiter and piloted the vehicle back to launch.

So there are two things we could try here.

In the stage of PP it seems to be in it’s running the land
vertical controller - but the vehicle isn’t coming down.

While we use the land controller in lots of places, it would be nice if
you could simply take the vehicle off in stabilize and just switch the
vehicle into “LAND” and see what happens.

The other thing we could do is ship you a binary with some debug enabled.
Are you happy to run such a binary?

@peterbarker - I am quite convinced the mission uploaded was fine given it
was just six instructions long and that the Package Place codes work. Maybe
it was just down to how I flight tested with no payload or how the gripper
was defined?

Amusingly, you don’t need a gripper defined to use this code :slight_smile:

It does tell you if you don’t have one defined, however.


(Seth Poh) #11

Hi @peterbarker.

I generally land my flights with the “LAND” mode. The mode seems to be working with no issue. In fact for the log you have analysed, I landed the vehicle with the “LAND” mode from loiter at the end of the test flight. I will try next taking off with stabilize and then the selecting the “LAND” mode. But unfortunately the next time can do any flight test is on Monday.

Yes sure. No problem with that. So I guess I load it with the load custom firmware option?

I figured that is sort of the case; allows one to use some sort of passive gravity hook with the Package Place. Just curious, where does it tell you if a gripper is not defined? Is it during the actual mission? Did not have my ground station connected during these tests.

Thanks for your help.