Auto Mission and Landing Question

The altitude is 10 feet at the final waypoint of a mission. The next command in the mission is RTL.

I’ve set the RTL altitude to be the altitude of the last waypoint (10 feet in my case). Also the final altitude is set to land.

However everytime the craft climbs to 15-20 feet before starting its landing descent.

There must be some other parameter at play here?

Thanks for any suggestions,


You haven’t said which parameters you changed to set the RTL altitude.

Supplying a data log from a flight would enable others to see which parameter might be involved here.

I am assuming at this stage you have set rtl-alt-rtl-altitude

Hey Mike,

Thanks for weighing in. Here are the main parameters I am using. I still think I’m missing something that makes it climb just before reaching the home location after RTL.

The altitude of the last waypoint before the RTL command is set to 10 feet. It should stay at 10 feet, then start the landing sequence.

Excerpts from the parameters and the DF log attached below.



3 6-2-2019 2-38-16 PM.bin (609.4 KB)

The first image “RTL_” values is all I ever set to return at existing altitude and land.

I could not see any particular vales in the parameters that would produce the effect you are seeing.
Having said that I am not familiar with the interactions of the FlowHold parameters, which I notice you have set.
There are also residual values in the RangeFinder field although you have the USE flag cleared.

Are you using an Optical Flow sensor?
Have you tried disabling that to see if you get the same result?
Try removing all values in the RangeFinder fields (shot in the dark, but you never know).
LAND_ALT_LOW might be another one to clear to make sure it’s not having an effect.

I don’t know how relevant this is, but at waypoint 3 your desired and actual pitch/roll diverge considerably.

Although this is a personal preference, I never use RTL as a mission command.
I always put a waypoint at the location I want to land and then the next mission item is a land command.
If you try this, does it produce a different result?

Sorry its not more definitive.


Thanks for the tips.

No rangefinder, no flow device.

Interesting on the behavior at WP3. From where are you making that graph?

I believe the LAND_ALT_LOW parameter is working as expected in my case. I’ve set it higher and lower and saw representative results. So I do not think it is that one.

I changed the last mission command to LAND at an appropriate waypoint in place of the RTL as the last command. With the LAND command in simulations the machine no longer climbs before landing. I’ll try it in real life once the winds abate here in NJ USA.


I flew the new flight plan with a LAND command at the end instead of the RTL command.

Worked well. However when it arrived at the final waypoint (WP3) it overshot by about 10 feet, then stayed at a constant altitude of about three feet or so while it hunted back toward the waypoint. Then it began its final slower descent (set at 185 cm) and landed.

I want it to enter the slow descent immediately when arriving near Waypoint 3 (WP3). The mission command for WP3’s altitude is 10 feet. The altitude at Waypoint 2 (WP2) is 50 feet and is about 80 feet away. The aircraft descends from WP2 to WP3 while descending from 50 to ten feet.

Can the parameters be adjusted so that it does not overshoot the final waypoint?

I’ve attached the DF log from the flight.



2019-06-04 19-32-09.bin (562.5 KB)