Arming and Disarming my rover from RC

I am having trouble arming/disarming my rover from RC.

I am following the documentation here.

I have tried both option 1 From the transmitter sticks and option 2 From a transmitter switch, neither of them arm the rover. I have no trouble arming the rover from Mission planner, so I know it is passing all the pre-arm checks. I have also checked that my rover is in Manual mode.

I would prefer to use a transmitter switch to arm/disarm my rover so I tried following the instructions here but the Ch7 opt dropdown is greyed out.

I have set up a switch to transmit on channel7 and when I flip the switch, I can see a response on Mission planner (under Initial Setup->Radio Calibration) in the Radio 7 Bar on the Radio calibration screen.

Either install Mission Planner Beta which will give you channel options on the basic tuning screen or go to the Full Parameter list and set RC7_OPTION to 41.

3 Likes

That worked perfectly, thank you.

1 Like

Hey, @r.rakshak! I have a similar problem. I have set up the switch for channel 7 and I can see from Mission Planner that I can Arm / Disarm. But my rover motors are working regardless of the arm / disarm state. Can you tell me what is your parameter configuration.

At early stage I disabled arming checks to get things working. If I use the ARM_CHECK parameter and Enable “Hardware Safety Switch” then I am unable to Arm at all (Mission Planner tells me to check Throttle and Steering configuration), but still my motors are working in the disarmed state.

@boga,

The arming message you’re seeing probably means that the outputs haven’t been setup correct. This wiki page outlines the SERVOx_FUNCTION values that should be set depending upon which vehicle type is being used.

Sure, which parameter value would you like to see.

I think you should check your outputs like @rmackay9 says, the pre arm checks are there for a reason.

Do you mean you can see the values for channel 7 change in Initial Setup->Radio Calibration or do you see Armed/disarmed on the artificial horizon?

When you say disarmed state, do you mean when MIssion planner reports that the FC is disarmed or that the you have fliped the switch on your controller?

Hey guys! I figured it out. Thank you @rmackay9 and @r.rakshak for helping.

It was my bad. If the rover is in Manual MODE and in DISARMED state the steering servos still work.

But my “Throttle” was configured so that I was receiving and just resending the RC signal to motors (basically just a bypass). Under servo output menu I selected RC1 for both of my motors so the ARMING and DISARMING did not do a thing, because I just bypassed the signal. I needed this to get the reverse working with the throttle stick.

As soon as I configured the servo output to “Throttle” arming and disarming worked as expected.

Also configured another switch for changing modes. Now I can put the boat to hold.

2 Likes