Servers by jDrones

Ardurover with esc problem

ardurover
dualmotor

(Dries Rondelez) #1

Hi All,

This is my first post, i am building an Ardurover boat but i'm having some problems.
I'm using the pixhawk px4, this is a dual engine setup, the ESC i'm using is a action electronics P94.
I cannot calibrate the esc via the mission planner, it keeps saying i need version 3.3?
Manual calibration doesn't work, i dont have beeps on my ESC.
When I go to advanced mode and go to motors test, it was denied by the auto pilot.
Skid steering is enabled.
If I arm my rover and switch to manual mode I have no output on my motors.(not in any mode)
I see input from my RC.

If i connect the ESC directly to the RC I can control my boat, so the ESC works.

Is this ESC incompatible with the pixhawk?


(gmorph) #2

Have you installed the Rover firmware on your Boat? Currently 3.1 is the latest - we don't have a 3.3.

Motor test doesn't work on Rover in the current firmware but will be available in an upcoming release.

Are you able to calibrate your ESCs without the Pixhawk? i.e. just doing it whatever the standard way is for those ESCs?

Thanks, Grant.


(Dries Rondelez) #3

Thx 4 the reply, is there a beta version available with motor test?


(gmorph) #4

Not yet. Hopefully this weekend.

Thanks, Grant.


(Dries Rondelez) #5

I've connected the ESC to my RC receiver and I can control my boat without problems.
Is it also possible to use 2 ESC's and let the pixhawk do the mixing control?
My current ESC is doing the mixing between the motors.


(Linus) #6

yes this ia possible with the Skid Steer Parameter

Cheers
Linus


(Dries Rondelez) #7

When I try to do a all in one calibration nothing happens, I've done the rc calibration as well and everything seems fine.
Is it possible the esc is not compatible with the pixhawk?


(Dries Rondelez) #8

I don't know why but for some reason it has incompatibility with some remotes, this is what i found in the manual :
THIS PRODUCT IS NOT COMPATIBLE WITH FUTABA 6J OR SKYSPORT 2.4GHZ RADIO SETS. The older Futaba 6EX 2.4GHz and 40MHz Skysport radios are fine

Maybe this is my problem?


(Linus) #9

could be the case.

Is this your ESC right ?

What mode is the ESC in ?
I see there are 4 modes available from the manual.

For skid steering you would need to setup Mode 1: Dual ESC Mode.
Also i think looking at the Autoset function and procedure is a good idea not sure if this plays a role here.


(Dries Rondelez) #10

This is my ESC, it is in mode 3 now.
I will try mode 1 this evening, Isn't it strange nothing happens now?


(Linus) #11

yes it is strange but couldbe configuration issue as well.
maybe Mode1 will do the trick.


(Dries Rondelez) #12

I've tried it in mode 1 but didn't work.

I've tried with other brushed ESC's from graupner and they work.
This problem is solved!

Thanks guys