ArduRover 4.5.2 Bad Compass Health

Hi, I have disabled armining check, why system continously reports “bad compass error”?

rover2.param (18.9 KB)

Disabling arming check only allows you to arm without satisfying arming requirements. It will still check component health, e.g. compass health.

Calibrate your compass instead :slight_smile:

Currently, I didn’t install the GPS(which has a compass), but I did configure a GPS UART port.

Is the configuration let FC think it has the compass module, so it will check the compass?

Actually, I need something like acro/stablized mode in copter, no GPS installed then it’s OK to arm, no GPS or compass warnings in manual??? mode(Rover).

So you don’t have a compass installed at all at the moment?

In that case set COMPASS_ENABLE to 0.

Thanks. It works.

It seems the software is NOT that smart or most of time ArduRover use compass!

Compass is a pretty standard component as it’s the easiest way to give you an absolute attitude reading (I think it’s considered a mandatory component by Ardupilot). A gyroscope will only know in what direction it’s pointing based on previous readings as reference.

The configuration part of Ardupilot isn’t smart at all, but that’s a good thing. It will do exactly what you tell it to do. So if you tell it to use a compass, Ardupilot excepts a compass. The error messages could be a bit more precise admittedly.


Yeah, I just thought it will behave as ArduCopter. It will not warning all the time,even if the flag is enabled when in stablized/acro mode.

Well, anyway, I’m NOT familiar with the ArduRover. So I didn’t think of this flag :frowning:

It’s a NOT big deal, as it’s working now. Thanks again for your help!

1 Like