ArduRover-4.2 doesn't do skid steer in Auto mode

Thanks again for all your support.

I have a crawler type rover, and it doesn’t work with skid steering in Auto mode.
This has been going on since I installed the ArduRover-4.2 firmware on my Pixhawk.

Do I need to further modify any of the full parameter list to enable skid steering in ArduRover-4.2?

If anyone knows more about this, please let me know.
Best regards.

SpreadKnowledge_Rover-4.2_fullparam.param (14.6 KB)

1 Like

can you drive it in acro mode? also a log file is more useful than a list of parameters.

1 Like

Thanks for the report. WP_PIVOT_ANGLE is 10 so it should pivot turn at the corners. As @geofrancis says an onboard log may help to figure out the issue.

I wonder if it is related to having avoidance enabled…

1 Like


Thank you both for pointing!
I checked skid steering operation in three modes: Manual mode, Acro mode, and Auto mode.

Servo’s log at that time is shown below.
Rover performed skid steering correctly when in Manual and Acro modes.
However, Rover still didn’t perform the skid steering when in Auto mode.

Looking at the Servo signal in the log file, we can see that the signal waveform is different only in Auto mode.

Before getting this data, I installed the Rover-4.2.2 firmware to Pixhawk and also set “WP_PIVOT_ANGLE” to “30”.

My Log file is below.