Ardurover 3.1.2, Skid Steer. Auto Mode Oscillation

Hallo Everyone,
I am currently trying to get Ardurover (on a Pixhawk) working on a Wild Thumper 4WD which is controlled by two normal brushed ESC’s.
I already disabled breaking on the ESC as one side of the drive stopped working in auto mode because it was braking instead of reversing.
Now it is working OK in manual.

However, I already tried a lot (also Rover 3.2, but results got worse). My settings are like in the Wiki so far, but in auto mode the rover is more or less “Walking” to its Waypoint. It seems the controller is overshooting and then correcting and overshooting again. I tried the PID setting and lowered Steer2Serv_P to 0,1. I also relocated the Pixhawk into the center of the frame and gave positions of the GPS Antenna in the settings. NavL1 Period is set to 5, but other Periods had no effect so far.

Has anyone successfully used a setup like this with skid steering and can tell me more about the PID settings?