Servers by jDrones

ArduRover 3.1.1 Arming Issue


(Ray N) #1

I currently have a Pixhawk installed on an Actobotics Nomad. I uploaded the Rover firmware (v3.1.1) through Mission Planner. I enabled Skid Steering through the Basic Parameters Tab. I am using a Futaba T10J with a FrySky Delta 8 receiver which is outputting CPPM. Calibrated the compass, accelerometer, RC input and modes. Went through all the recommended initial setup.

When I initially tried to arm the Pixhawk by holding the Throttle centered and then Steering hard right (as suggested in the documentation), it didn’t arm at all. I then disabled ARMING_CHECK, guessing that it wasn’t able to get through one of the checks. And yet it still won’t arm. I disabled the Safety Switch to see if that would help and again it won’t arm. So I disabled SKID STEERING (IN and OUT) and now it arms with the throttle down at about 1100 and steering hard right. However it does not disarm, with the throttle at 1100 (LOW) and steering hard left. It still does not arm in the Skid Steer mode, which is essential for this chassis, which doesn’t have traditional steering.

A few additional things to note. I tried a different receiver and transmitter setup (DX6i with R615X receiver) and the same problem persisted. I uploaded Quadcopter firmware through Mission Planner to see if the arming issue was present with other types of firmware. With the Quad Firmware, the board armed with absolutely no issues whatsoever.

I am new to the Pixhawk platform and any help would be greatly appreciated. I’ve tried to methodically troubleshoot this for the last week and have hit a dead end.


(Linus) #2

Hi RayN, can you try if it will do when arming from GCS software Missionplanner, APMplanner, etc ?


(Ray N) #3

This is probably a stupid question, but I’ll ask it anyway. How exactly does one arm directly from Mission Planner or APM planner? I have both installed and I can’t seem to see the option to arm anywhere. Am I missing something? And my version of Mission Planner doesn’t seem to have Terminal anymore, so sending it a command that way also seems not to work. I would appreciate the guidance.


(Dave) #4

On the Actions tab below the HUD in MP. Arm/Disarm button


(Ray N) #5

I’ve tried that. And the only three option available under the Actions Tab are, Auto, RTL, Loiter. This is when the pixhawk is in the Manual Mode. I am just trying to at least get it to arm first in the Manual Mode.


(gmorph) #6

In MP in the Config/Tuning screen down the bottom there is a “Layout” drop down box. Select Advanced in that and then head back to the Actions tab below the HUD and see if Arm/Disarm is there. You may need to restart MP.

Thanks, Grant.


(manulrk) #7

I am “EXACTLY” in you situation…, grrrrrrrrrrr

I am able to arm with Thr=0 and Steering(Ail) to the right.
I am unable to disarm via the transmitter! Only in the MP. Frustrating.

Thanks,
manu
PS: is the rover able to drive in reverse? (thr > 1500 = foreward, thr <1500 = brake and reverse)


(Thomas J Coyle III) #8

@manulrk,
What joystick are you using for your throttle?
ArduRover firmware is expecting the Pitch joystick to be the throttle input and not the Throttle joystick.
When using the Pitch joystick for the throttle input you will have forward and reverse if your ESC is programmed for forward and reverse.
Have you followed these Wiki Arming Instructions?
Regards,
TCIII AVD


(Dave) #9

No problem with forward and reverse. I didn’t like the center stick neutral position so I setup a mix on the radio with a forward/reverse switch. Low throttle is neutral and full forward/full reverse with the switch position. Works really well!


(Thomas J Coyle III) #10

@dkemxr,
Since I competed successfully in various Rover competitions at very high speeds I found that being able to switch from Auto to Manual instantly and pull the joystick back for full reverse saved the bacon many times when my Rover was headed for a crash.
Regards,
TCIII AVD


(Dave) #11

Thank you for the sage advise Thomas. I’m sure there are many circumstance I haven’t properly considered as I get this Rover project rolling.


(manulrk) #12

Hi, thanks for the reply.

I still have the problem of disarming after putting the “throttle” on the “pitch” channel. (mode 2)
Arming works (steering stick to the right in manual mode), serov1-out for steering, servo2-out for throttle works.

I can only disarm via hardware-safety-switch or in the GS. Not possible with steering stick (ail) to the left…

Arming (“roll”) stick to the right => warning : hardware-safety-switch => press it => tu-tu-teet beep =>
hardware-safety-switch => press it => led blinks => hardware-safety-switch => press it => tu-tu-teet beep (again) => stick to the right => armed! => hardware-safety-switch => press it => disarmed => hardware-safety-switch => press it => no beeps and just armed !

manu


(gmorph) #13

Are you using a skid steering rover? You can’t disarm a skid steering rover from the transmitter because it would turn left as you were trying to disarm. This was original on the wiki but appears to have disappeared. I’ll put it back.

manuirk if your not using a skid steering rover please attach a log file and I will have a look.

Thanks, Grant.


(Khancyr) #14

@gmorph the problem is also present on SITL on both normal and skid steer !


(gmorph) #15

Really? Damn. I disarmed on my real Rover over the weekend so its odd. I’m in the middle of something but I will look into it as soon as I can.

Thanks, Grant.


(manulrk) #16

skid_steer_in and out are both 0.
apmlog_20170221.txt (145.8 KB)

Thanks
manu


(Thomas J Coyle III) #17

@manulrk,
Skid_Steer_Out should be 1 as a minimum for skid steering to function.
Regards,
TCIII AVD


(manulrk) #18

I have a normal rc-car, 1 servo for the steering.
Mode-2, Ch1(Elev)=Throttle, Ch2(Ail/Roll)=Left/Right
Arming= Ch1 middle, Ch2 to the right
Disarming= Ch1 middle, Ch2 to the LEFT ?

Thanks
manu


(manulrk) #19

Hi, any feedback on this issue?
thanks
manu


(gmorph) #20

I have just fixed my other issue so I will get to this shortly.

Thanks, Grant.